Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After Installing GeoServer on my windows machine, then I restarted tomcat but it doesn't start.

Before installing the geoserver localhost:8080 is working.

What's wrong ?

share|improve this question
Welcome to SE.GIS forum. What error you are getting ? Which version you are using ? Please check… – Sunil Mar 16 '13 at 6:48
Might be port problem .Turn off the IIS (which I think installed on 8080 port OR install geoserver on different port i.e 8082 etc. ) – Sunil Mar 16 '13 at 6:50
Do you have a firewall running? I have had to open the specific port in Windows firewall when I had faced such an issue. – Devdatta Tengshe Mar 16 '13 at 7:04

I had the same issue on port 8080. Switching to 8000 worked for least it still is working.

share|improve this answer

Turn off your firewall and see if the problem goes away. if so, open that port in the firewall.

If not, 8080 is used by a lot of applications, you probably have something installed that is using that port

either way, it would be advisable to change the geoserver port to somethimg obscure and ensure that it gets opened through the firewall

share|improve this answer

unistall your geoserver and re-install it with another port number. for example 8090, it should be work.

share|improve this answer

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

Hello :-) The approach is rather crude. You should be able to assign a new port number in a config file and then restart the service. – ragnvald Mar 9 '15 at 12:54
Hello.. i had this problem too and i changed the number of ports and now it works! – Shokouh Dareshiri Mar 10 '15 at 17:16

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.