Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I've recently installed arcgis server 10.1, but I'm not sure if it installed correctly, or if the proper ports are open. Here is my reasoning and I may be off:

1) When publishing a new service(i.e newMap), the folder "arcgisserver\directories\arcgisoutput\newMap" remains empty, I'm assuming their should be a copy of the service in there now.

2) When trying to access the service through arcgis javascript api, I get a blank page. I copied and pasted the source code from the tab or window that pops up when you press "view" in the services thumbnail into a .html file. Then I replaced the url with the REST URL given to me under the services' capabilities options. I've also tried replacing localhost with my machine name and I still get a blank page.

http://localhost/myorg/rest/services/MyMapService/MapServer

If anyone can provide me with some working test code, that would be great, as I'm learning to use javascript api and server at the moment and I want to make sure its configured correctly. Thank you.

share|improve this question
add comment

1 Answer

The best way to check if your ArcGIS server is working, is to consume the services from it in ArcGIS desktop.

Please see this page for ways in which you can add service to your ArcMap: Adding ArcGIS Server map services

Coming to your issues:

  1. No copy of a service is made in arcgisserver\directories\arcgisoutput\newMap. You need to check the arcgisinput folder instead.

  2. There could be many reasons why you are not seeing the output in the 'View in ArcGIS JavaScript' link. First make sure that your services are running and consumable. Only after that tackle this problem.

share|improve this answer
    
Thanks Devdatta, I was able to add my map service successfully in ArcMap. 2) I am able to see the output of the "view in arcgis javascript", what I am having trouble doing is accessing a service through HTML/Javascript using REST URL. –  figsology Mar 21 '13 at 7:29
    
Have you gone through the tutorials? help.arcgis.com/en/webapi/javascript/arcgis/jstutorials Can you try using this sample with your service:help.arcgis.com/en/webapi/javascript/arcgis/jssamples/… –  Devdatta Tengshe Mar 21 '13 at 7:59
    
Thanks for the sample! Locally the code supplied with the sample service and the url "gm2:6080/arcgis/rest/services/MyMapService/MapServer"; displayed exactly what I needed. But when I uploaded this file to my ftp server it didn't work. I get a blank box with the esri logo on the bottom right(gisinsight.com/gis/test3.html). How can I fix this? –  figsology Mar 21 '13 at 9:02
    
Generally you need to put your HTML file in a web server; And to debug issues, you need Firebug. and see what outputs and errors it gives. –  Devdatta Tengshe Mar 21 '13 at 9:06
    
So I need a web server in conjunction with arcgis server to be able to have people access web maps made using javascript api? Interesting, will an apache web server do the job? Actually I just read that it is not supported. Any ideas? –  figsology Mar 21 '13 at 9:52
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.