Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

Is it possible to use only Ext JS 4.2 and OpenLayers 2.12 without GeoExt or anything else? (to make a basic map application) I couldn't find any example.

share|improve this question
2  
    
thanks for your comment. it will be usefull guide for my start. –  adanali Mar 21 '13 at 14:40
add comment

3 Answers

up vote 1 down vote accepted

Since GeoExt is based on OpenLayers + Extjs. So basically what you are trying to do is make your own GeoExt like thing.

If you want to use Extjs, because of its better display functions. Using GeoExt will be your best choice.

If you do not need Extjs, Openlayers can be used like using javascript.

Using or not using Extjs, depends on how comfortable you are with OpenLayers. If you are newbie, use OpenLayers without Extjs. Using both at once without proficiency in any will be big problem during debugging.

share|improve this answer
    
thanks for your answer. yes i'm new to GIS.I think GeoExt may not be sufficient for my company's some applications. –  adanali Mar 21 '13 at 14:32
    
I think GeoExt may not be sufficient for my company's some applications in future. So i want to write all codes myself. And i want Extjs's good display functions. So i will use (only) Ext JS 4 and OpenLayers. –  adanali Mar 21 '13 at 14:38
    
GeoEXT is so powerful and I used it in many cases and saw a lot of incredible applications, like a full desktop-GIS in a Browser. So no need to reinvent the wheel again. If you have the need for new functionalities, extend it. –  Torsten Mar 21 '13 at 19:09
add comment

GeoEXT and OpenLayers or any JS library and OpenLayers are not directly connected. You can find many, many examples at OpenLayers relying on pure HTML and OpenLayers. These are usually single use cases, but it should get you going.

share|improve this answer
    
As i previously said, i want my app to be minimum sized and simple, untroubled as much as possible. –  adanali Mar 21 '13 at 14:47
    
So? What is wrong with the apporach of using OpenLayer only? Simple, mimimum sized and extendable. (You should rate some answers, if they suit you. I actually think that all answers point you in the right direction) –  Torsten Mar 21 '13 at 19:06
    
As i said before i'm new to GIS. Of course i don't want to reinvent the wheel again but i want to learn what codes means what. But i will try GeoExt2 with ExtJS4 and Ol-12.2 according to your words. (And I don't know how i can rate some answers) –  adanali Mar 22 '13 at 8:03
    
One problem again GeoExt2 is not compatible with Ext JS 4.2.0 ; GeoExt2 works wiht only Ext JS 4.1.*. –  adanali Mar 22 '13 at 16:34
add comment

I made applications with OpenLayers and ExtJS 4. GeoExt was limited to ExtJS 3 when I began. But it will always lag behind the latest developments. Another reason was that I was not so free with the design of the GUI elements, GeoExt has good easy to use solutions but limits the creativity. It depends on your purpose. If you want to tailor your webmap to the needs of your company, then is ExtJS 4 the better choice. lumobu

share|improve this answer
1  
I'm not sure how this answers the OP's Question. –  Devdatta Tengshe Oct 24 '13 at 10:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.