Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using the ArcGIS Silverlight API to edit data in an ArcSDE SQL Server geodatabase.

I have been told that any editable feature classes must be registered as versioned in ArcCatalog before they can be edited via the Silverlight API.

Does anyone know why this is the case? From what I understand, you can not use the Silverlight API to edit versioned data in a feature class, so I'm not clear on why you would have to register the feature classes as versioned.

share|improve this question

Here's what the online doc says:

Versioned and unversioned data is supported; however, versioning is required if you plan on editing nonsimple types (for example, network edges) with the service.

Also verify that the Editor has been configured for non-versioned editing.

share|improve this answer
As far as I know, the Silverlight API is requiring it for all types. The feature class I'm editing on is just points. – Seth P. Jan 26 '11 at 21:37
Non-versioned data is supported. From the ArcGIS SLAPI help (and I've personally used SL to edit non-versioned feature classes)… "The ArcGIS Silverlight/WPF API provides simple feature editing. The features must come from an ArcSDE geodatabase hosted in an ArcGIS Server feature service. This geodatabase can be licensed for either workgroup or enterprise use and does not have to be versioned" – wwnick Jan 26 '11 at 22:40
@Seth - To troubleshoot, I'd try this: rightclick on arcmap from the startup menu and choose "run as", enter the credentials of the arcgissoc user account. Start editing and see if you can edit. If you can't edit you either need to grant privs to the arcgissoc account or use dbms authentication for the arcsde connection. – Kirk Kuykendall Jan 26 '11 at 23:16
@wwnick I did try editing on a non-versioned feature class. I was able to make edits, but not save them using the Silverlight template provided by ESRI. Once I made the feature class versioned, it worked correctly. – Seth P. Jan 27 '11 at 4:19
@seth - did fiddler show any errors when you tried to save? – Kirk Kuykendall Jan 27 '11 at 14:13

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.