Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I compiled Grass7 on Ubuntu 12.10, with liblas in order to run r.in.lidar and v.in.lidar. I now want to import .las data; the option in file -> import raster data -> LAS LIDAR points import is given and enabled, but when I select it nothing happens. Any idea where the bug could be?

share|improve this question
    
Please check the console for error messages and post them here (bu editing your posting). –  markusN Mar 25 '13 at 14:06
    
Seems to be a problem with liblas: Unable to fetch interface description for command 'r.in.lidar'. Details: r.in.lidar: error while loading shared libraries: liblas_c.so.2.2.0: cannot open shared object file: No such file or directory –  Peter Mar 25 '13 at 14:37
    
Addition: running lasinfo from terminal works –  Peter Mar 25 '13 at 15:02
add comment

1 Answer

up vote 2 down vote accepted

Problem solved. Did a "make clean" (that is what I omitted before), then again $ "-g -Wall" ./configure --with-liblas=/usr/local/bin/liblas-config, followed by make and sudo make install. Works now!

share|improve this answer
    
Excellent (note that "male distclean" is better to really clean up stuff). Please accept your answer to close the issue here. –  markusN Mar 26 '13 at 6:57
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.