Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I'm working in an area in Baden-Württemberg, Germany. I loaded some OSM data in QGIS but the map display is distorted.

I tried ftools define projection with many different projections but nothing changed.

I tried: - WGS 84/ World Mercator - DHDN / Gauss-Kruger zone 2 - Google mercator - ETRS89 / UTM zone 32N - DHDN / Gauss-Krugerzone 3 - DHDN / Soldner Berlin

and many others...but nothing worked. There was no difference visible.


ich bearbeite derzeit ein Gebiet in Baden-Württemberg und habe dazu Daten aus OpenStreet Map in QGIS geladen. Leider wird das Gebiet immer in der Breite verzerrt dargestellt. Ich habe über Rechtsklick auf den Layer und auch über fTools->Aktuelle Projektion definieren schon viele verschiedene Projektionen ausprobiert, jedoch ändert keine was an dieser Verzerrung. Könnte mir jemand helfen, wie ich den Layer richtig darstellen kann? Vielen Dank!

share|improve this question
1  
Dear Lisa, what projections did you use and to what projection did you transform? Did you try to recreate your layer with the intended transformation? OSM usually ships in WGS84 and what you probably want is something like DHDN/GK-3 or similar. –  Curlew Mar 25 '13 at 17:39

1 Answer 1

The basic thing you are stumbling upon is the difference between layer CSR and project CRS.

The Openstreetmap data is in lat/long degrees, so that layer should have the CRS EPSG:4326. You can set it with right-click on the layer -> Set CRS for layer.

The project CRS can be different, and should be in your case. You can change tthat with Settings -> Project Settings.

EPSG:3857 should be the projection you are used to when looking at the Openstreetmap Website.

And On-the-fly-projection should be activated.

share|improve this answer
    
Dear Andre,thank you so much for your advice. Your are right, that is my basic problem ;) but your answer helped me and I could fix the problem. Thanks!! –  Lisa E. Mar 27 '13 at 10:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.