Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I'm trying to create an ArcGIS tool which accepts an SDE connection file as an input. I made a new interface with an input parameter and set the type to Database Connections. When I open the tool and click the "browse" icon, the dialog opens to the Database Connections folder but there is nothing in it. If I navigate to Database Connections in the ArcCatalog window however I see all my usual connection files. Does anyone know why the tool would not be displaying those?

enter image description here

share|improve this question
1  
possible duplicate of Definitions of arcgis script parameter Data Type options –  blah238 Mar 26 '13 at 22:15
    
Thanks, blah. I took a look at the definitions and see that Database Connections is essentially a reference to the folder, but I don't see why there would be nothing in it. Still hoping for some kind of insight on this. –  Mapbert Mar 26 '13 at 22:37
    
Ask ESRI, I have no idea :) –  blah238 Mar 26 '13 at 23:28
    
I started a case a case with Esri support - so far there have been no answers. I smell a bug! :D –  Mapbert Mar 28 '13 at 17:14
add comment

1 Answer

up vote 3 down vote accepted

Robercik, it maybe not obvious, but in order to be able to access the ArcSDE geodatabase connections under the Database Connections folder while browsing from a script tool dialog box, you have to make your script parameter to be of Workspace type.

Esri help page on setting script tool parameters. Check the Filter section - when you have a parameter of the Workspace type you can filter what type of workspaces will be available. In your case, you might leave only the Remote Database filter value, which will let the end user see only the ArcSDE connection files either under the Database Connections folder (the default location) or anywhere else on the disk if you would copy them to some other place.

share|improve this answer
    
I never, EVER would have thought to try Workspace but that's exactly what I needed! Thank you Alex! –  Mapbert Mar 28 '13 at 17:13
    
Even after reading the duplicate question? :) –  blah238 Mar 28 '13 at 17:17
    
Sorry blah, I think my blinders were on at the time. The Workspace thing just didn't register. –  Mapbert Mar 28 '13 at 21:38
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.