Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

We have some GIS data, which was converted from AutoCAD dwg to TAB using mapinfo, then converted to shapefiles as that's what we are required to create. Editing the data fields was done in the shape files using QGis.

Now for some of the files, the coordinate system settings created using MapInfo were wrong, so I tried to solve this by using the 'save as' option on the edited shapefiles from within QGis, setting the correct projection.

For me, all lines up as it should. However, for the one requiring the data (using Esri software) it doesn't.

I think this is due to QGis creating a .qpj file along the .prj file, and QGis knows to look at the qpj but esri software doesn't.

First of all: Could this interpretation be correct?

Second: if it is correct, how do I 'fix' this so it aligns as it should in the Esri software?

share|improve this question
    
What Esri software product (and version) are you targeting? –  PolyGeo Mar 27 '13 at 10:13
    
The data I have to supply is to a government instance, which - as far as I'm aware off - uses ArcGis to combine the datasets they get as input, as far as I can tell they use ArcIMS to display it as web content. –  Tim Couwelier Mar 27 '13 at 10:24
    
Sounds like ArcGIS Desktop (am guessing 9.x rather than 10) - I've added a few tags to try to get this in front of those more familiar with coordinate system issues when transferring data between GIS products than I am. –  PolyGeo Mar 27 '13 at 10:28
    
Thank you.I tried adding prj and qpj, but those appear to be 'new tags' which one can only add from 300 reputation onwards. –  Tim Couwelier Mar 27 '13 at 10:36
    
How big is the offset in ArcMap? If it's under a 100 m and there's a mix of geographic CRS (datums) in use, the ArcMap user may need to set a geographic/datum transformation. If the offset is larger, then I would suspect a incorrect coordinate system definition. –  mkennedy Mar 27 '13 at 17:21

1 Answer 1

In the original shapefile specification, projection information is stored in the prj file using Well Known Text format. QGIS is using proj strings that are bound to EPSG codes. These EPSG codes are normally missing in prj files, which may lead to wrong CRS detection by QGIS. That's why QGIS writes its own .qpj projection file in addition.

On the other hand, the datum shift between WGS 84 and the datum used is not stored in the prj file by values, because ESRI do that in another way than QGIS. So I guess that's why you encounter differences. And some projection methods may have different names for the same thing in both worlds, which may lead to misunderstanding on both sides.


EDIT

For Belgian Lambert 72, QGIS Master writes the following into the prj file:

PROJCS["Belge_1972_Belgian_Lambert_72",GEOGCS["GCS_Belge 1972",DATUM["D_Belge_1972",SPHEROID["International_1924",6378388,297]],PRIMEM["Greenwich",0],UNIT["Degree",0.017453292519943295]],PROJECTION["Lambert_Conformal_Conic"],PARAMETER["standard_parallel_1",51.16666723333333],PARAMETER["standard_parallel_2",49.8333339],PARAMETER["latitude_of_origin",90],PARAMETER["central_meridian",4.367486666666666],PARAMETER["false_easting",150000.013],PARAMETER["false_northing",5400088.438],UNIT["Meter",1]]

Maybe ARCGIS likes this better, as there are no unknowns inside. Or take it from http://spatialreference.org/ref/epsg/31370/

share|improve this answer
    
filedropper.com/rup360102140000300001gv for the prj, filedropper.com/rup360102140000300001gv_1 for the qpj It's the fact that it lined up as it should for me and not for the recipient that stumped me. In case it helps/matters: EPSG31370 for Belgian Lambert 72 is the projection it needs to be in. –  Tim Couwelier Mar 27 '13 at 13:34
    
I have tried to edit the .prj file to what you listed. It works fine in QGis (with either just the prj, just the qpj or both). Esri ArcGis Explorer fails with both options. I think that proves the point that when prj and qpj are present, ESRI software only looks at the prj. However, altering the .prj contents to what's listed above made ESRI say that it had an unknown coördinate system. –  Tim Couwelier Mar 28 '13 at 8:07
    
Ok, do it the other way round: Create a shapefile in Arcgis in Belgian Lambert 72, and copy the .prj file from that. I think ESRI does not look at all at the .qpj file. –  AndreJ Mar 28 '13 at 9:14
    
Yea, the key bit about that - I don't have Arcgis to do that. The thing I have lets me view content but not create it. –  Tim Couwelier Mar 28 '13 at 10:31
    
Anyone else have an insight on how I could solve this? It should be so that in normal circumstances the SHP requires neither PRJ or QPJ, so whatever workaround I use will leave me - at best - with a PRJ file that makes it align correctly. –  Tim Couwelier Apr 2 '13 at 11:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.