Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I tried to compile QGIS master branch 1.9 (qgis-Quantum-GIS-b99ff61) under CentOS for many hours now as explained here and here / here

Compilation:

[  7%] Generating ui_qgsmapserverexportbase.py
File "/usr/lib64/python2.6/site-packages/PyQt4/uic/pyuic.py", line 2
exec /usr/bin/python /usr/lib64/python2.6/site-packages/PyQt4/uic/pyuic.py ${1+"$@"}
     ^
SyntaxError: invalid syntax
make[2]: *** [python/plugins/mapserver_export/ui_qgsmapserverexportbase.py] Error 1
make[1]: *** [python/plugins/mapserver_export/CMakeFiles/mapserver_export-.-stageinstall.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
[  7%] Built target sextante-._otb_description-stageinstall
make: *** [all] Error 2

Against:

  • PyQt 4.10
  • Qt 4.6.2-26
  • Scintilla 3.3
  • Sip 4.14.5
  • QScintilla 2.7.1 (closest to Python 2.6.6 on CentOS)

I am without any idea how to solve this compilation. PyQt is working and can be imported.

share|improve this question
    
pyuic.py is part of pyqt-devel package. It is there right? –  nickves Apr 3 '13 at 7:51
    
I compiled PyQt from source. pyuic.py is also located where the exec command points to. –  Frank Apr 3 '13 at 8:26
    
I'm not getting the error with a yum installed PyQt4 version 4.6.2. Can you find out what arguments are being passed in '${1+"$@"}' and run 'pyuic' from the command line? –  MonsterMushroom Jul 9 '13 at 9:05
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.