Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I am using ESRI GeometryEnvironmentClass that implements IGeometryFactory3 and I use the method CreateGeometryFromWkbVariant. For the same wkb, in ESRI 9.3.1 the returned polygon is oriented clockwise, but in ESRI 10.0.0 it seems that it is counter-clockwise.

(I have found this out using the method IsSimpleEx in ITopologicalOperator3 interface: in 9.3.1 the polygon is simple, but in 10 it is not, with reason esriNonSimpleRingOrientation - "A polygon is topologically simple, but its rings may not be oriented correctly (outer rings - cw, inner rings - ccw)".)

Any idea what changed? Why was it working in 9.3.1 and no longer works in 10?

Thank you.

share|improve this question
    
I had a similar issue, and was surprised to find nothing in the OGC spec about polygon orientation. Have you listed out the coordinates from the wkb to confirm that they are oriented correctly before converting to an IPolygon? –  Kirk Kuykendall Apr 3 '13 at 14:06
    
How does the polygon geometry look in the original WKB/WKT? It may be the case that the behaviour was wrong at 9.3.1 and is correct (fixed) at 10+. Anyway, you can probably call ITopologicalOperator.Simplify (or IPolygon4.SimplifyEx for more control) to simplify the geometry. –  Petr Krebs Apr 3 '13 at 19:13
2  
This question appears to be off-topic because it is about an issue that has no answers or comments since the day it was asked 6 months ago, and the asker has not logged in during the past 6 months. –  PolyGeo Oct 2 '13 at 5:12
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.