Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I did recently ask a question about how to add a new point to a PostGIS table. Now when I've got the new point in the table it should be visible on my map, but it isn't.

I'm using Mapnik together with TileStache. The cache for TileStache is temporary turned off, and I've restarted PostgreSQL. It's still not there.

The query I used to add the point was the following:

INSERT INTO osm_transport_points(osm_id, name, type, geometry)
VALUES(1, 'name', 'station', ST_SetSRID(ST_MakePoint(lat, lng), 900913));

Is there something I've missed to flush, or am I doing something else wrong?

share|improve this question
    
Other questions/answers have mentioned that ST_MakePoint should be (lng, lat). –  mkennedy Apr 3 '13 at 15:57
    
Ah, that's true. I've tested that now as well, but there's no difference. –  Ivar Apr 3 '13 at 16:59
1  
What debugging have you done? Does the point show up if you do a query for that point? Is the osm_id unique? Does the SRID for the geometry match the specified SRID for the column? –  BradHards Apr 5 '13 at 21:51
    
The only query I ran for debugging was to see if I could fetch the right coordinates from the geometry column, which I could. The SRID is the same as stated in the table geometry_columns. The osm_id is unique but only one digit, I don't know if that matters or not. –  Ivar Apr 6 '13 at 11:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.