Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

This question already has an answer here:

I would like to convert .shp into .gpx. I tried to "save as" gpx but it gives an OGR error:

creation of field ObjectId failed (OGR error: Field of name 'Name' is not supported in GPX schema. Use GPX_USE_EXTENSIONS creation option to allow use of the element.)

GPX_USE_EXTENSIONS=Y does not work. Checking 'Skip Attribute Creation' does not work.

share|improve this question

marked as duplicate by underdark Apr 3 '13 at 15:15

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer 1

In the first input box, insert: GPX_USE_EXTENSIONS=YES

and probably you want also FORCE_GPX_TRACK=YES in the second input box.

share|improve this answer
    
Still doesn't work. Pretends to, but the gpx cannot be imported into Mapsource/GPS. –  Allison Apr 3 '13 at 19:18
    
Can you add it to QGIS with GPS Tools (Not using Add Vector Layer)? Can you open it with a text editor? Was target CRS set to EPSG:4326 WGS84? –  Andre Joost Apr 4 '13 at 4:14
    
I did not try to add it to QGIS (did not think of it, as that is not where I need it). CRS layer was set to UTM, as that is what our GPS's are set for. –  Allison Apr 4 '13 at 12:30
    
Tried adding to QGIS - does not work. I converted it using DNR Garmin, but it would be nice if QGIS would do it. Thanks for your help. –  Allison Apr 4 '13 at 12:40
    
CRS of the layer must be set to WGS84 for GPX, regardless what you have set your GPS units display to. Thats the definition of GPX, see en.wikipedia.org/wiki/GPS_eXchange_Format –  Andre Joost Apr 4 '13 at 14:01

Not the answer you're looking for? Browse other questions tagged or ask your own question.