Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I am installing QGIS and GRASS as part of an FOSS GIS class I'll be teaching this summer. I used the OsGeo4W installer. This installer has always worked flawlessly for me except on the machines at the college.

Initially the install gave me a "The ordinal 3109 could not located in the dynamic link library LIBEAY32.dll" error. I remembered the work around for this from last spring. I copied the libeay32.dll from c:\osgeo4w\bin to c:\osgeo4w\qgis\apps\bin and was able to complete the install and have QGIS operate successfully.

However, when I enable the GRASS plugin, open a mapset and then try to add data I get the following and QGIS crashes.

Cannot get projection
Cannot run module
Command: c:/osgeo4w/apps/QGIS/./grass/modules/QGIS.g.info info=project

The layer itself has a defined coordinate system and the QGIS project is set to the same coordinate system.

If I create a new Mapset it fails to import an existing dataset, either from a loaded dataset, or via OGR. I get this error:

Cannot start module v.in.ogr

Command: c:/osgeo4w/apps/grass/GRASS--1.2/bin/v.in.ogr.exe --interface-description

GRASS itself will not open via either GUI or commandline.

I've gone into the OsGeo4W installer/Advanced and reinstalled both QGIS and GRASS without any change.

I need to get this up and running by the end of the week. Any suggestions will be greatly appreciated. All I can think of is that perhaps there are restrictive permissions on some folders. The computer is a Windows 7 64 bit machine.

Thanks! Kurt

share|improve this question
    
Have you tried using the new SEXTANTE plugin? –  Nathan W Apr 3 '13 at 22:08
    
Yes but not on this machine. Are you thinking I should try accessing the GRASS tools via the SEXTANTE plugin? –  Kurt Menke Apr 4 '13 at 15:56
    
I have figured out how to troubleshoot this on the college machines. Copy all the dll's from OsGeo4W/apps/grass/Grass-6.4.BRC2/lib and OsGeo4W/apps/qgis/grass/bin to both OsGeo4W/apps/grass/Grass-6.4.BRC2/bin and Osgeo4W/apps/qgis/grass/modules. I imagine there should be links to these dll files versus having the dll's having to be in those folders. On my laptop and workstation these dll's aren't in these folders and QGIS and GRASS run fine. However, given the time contraints this duct tape fix appears to be working. –  Kurt Menke Apr 9 '13 at 17:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.