Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I am trying to run a function from ArcHydro tools in Arcmap 10.1; Sink evaluation. But before it can finish it returns an error message, that, frankly, I don't understand at all. It goes *System.runtime.interopservices.comexception (0x80004005): error hresult e_fail* .

Can anyone help me solve this? I have tried all I can think of. Run the function from the toolbox instead of dropdown menus, shorten paths, restart Arcmap, reinstall AHT, open new map documents, restart my computer, wait till next day and see if it automagically have fixed itself...

After searching this forum I found a possible duplicate, although it's got no answers. Now I'm all out of ideas, can anyone please help me?!

enter image description here

I'm using ArcMap 10.1 SP1 basic license and Windows 7.

EDIT: I think I have narrowed it down a bit, still not clear what's wrong though. Sink evaluation uses a series of functions in Arcmap, of which one is Zonal statistics as table. That's the one it gets stuck on. The input raster somehow does not exist, path unknown. I guess this is some intermediary raster.

enter image description here

EDIT2: After consulting the Archydro team, I got the advice not to use grids stored in a gdb (which I didn't). I have also tried to change target locations, thanks to @G.Oxsen. Unfortunately neither of those solved the issue. According to the Archydro team, GPL0 that I asked about earlier is an in-memory grid, so probably no problem there.

I am currently pursuing that it is related to the installation of SP1. Anyone out there using AHT with SP1 and got Sink evaluation working?

EDIT3: Uninstalling SP1 did not change anything, unfortunately. Still working on this, but with less intensity. Seems like I'll have to find workarounds...

Final Edit: By reducing the number of sinks in need of processing I managed to get Sink evaluation running. Having the files not stored in a gdb seem to help as well, as mentioned earlier, and using integer grids. Changing the "Maximum number of uniqe values to render" in ArcMap Options (Customize menu), tab Raster --> Raster dataset is another tip that I got (from the ArcHydro Team). Restarting Arcmap after running every one or two functions also helps keeping things stable.

share|improve this question
    
I had a problem with the ArcHydro 10.1 beta as well. What fixed it for me was running Windows Update and installing some patches that I had missed, including some "Optional" patches. It sounds weird, but it worked for me. –  dmahr Apr 4 '13 at 13:01
add comment

2 Answers

up vote 1 down vote accepted

I got a little bit different error(s) while running Sink evaluation and basic deranged terrain processing.

Anyhow, these steps might solve other errors too so here's what helped:

  1. I moved all of my data under C:\data\
  2. I created new file geodatabase (named testing.gdb) under that folder
  3. I increased the max number of unique values to render
  4. I set out the targets (C:\data for raster and C:\data\testing.gdb for vector files) using ApUtilites
  5. I set out the processing extent to the extent of my DEM (Geoprocessings>Environments>Processing extent ) )
  6. I saved my project as testing.mxd under C:\data
  7. I set testing.gdb to be default workspace. (this finally solved the last errors I was getting)
  8. I also named my data frame simply to "data" since ArcHydro -tools tend to add data frame name to output-file paths. I'm not sure if step this is needed.
share|improve this answer
    
Very nice ideas! I should check them out next time I'm calculating catchments, since I still get these error messages regularly. –  Martin Feb 17 at 9:33
    
I think what's the most helpful is keeping everything at C:/ instead of a network drive, along with avoiding shapefiles. This is also a very useful ArcHydro forums thread. –  Martin Mar 20 at 8:15
add comment

I had a similar problem with archydro tools in ArcGIS 10.0 Try going to the archydro tool bar and go to ApUtilities>Set Target Location. Go into each section in that list and edit the Raster Data target locations. Make sure the location is targeted to a standard folder and not a .gdb or .mdb (in the selection window make sure the "Show of type:" field is set to "Shapefile/Raster Workspace" and not "Personal/File Geodatabase"). You may be able to accomplish the same goal through the environment options (Geoprocessing drop down menu ) by changing the workspace environment to a regular folder and not a .gdb or .mdb, but I would not mess with the workspace environment unless I had to. Changing the workspace environment will affect all of the processes not just the raster environment for archydro tools. Let me know if this helps.

share|improve this answer
    
I'm afraid it didn't :( Thanks for your help though! It might be related to SP1 of Arcmap 10.1, but still looking in to that. I'll get back here with a solution as soon as I find it. –  Martin Apr 5 '13 at 8:10
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.