Sign up ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I am just trying to start using GRASS, but am having problems setting up.

This is the error message I get:

WELCOME TO GRASS              Version 6.4.2         2012

   1) Have at your side all available GRASS tutorials

   2) When working on your location, the following materials
      are extremely useful:
      - A topo map of your area
      - Current catalog of available computer maps

   3) Check the GRASS webpages for feedback mailinglists and more:

Hit RETURN to continue

Starting GRASS ...
Traceback (most recent call last):
  File "/Applications/", line 35, in <module>
    from gui_modules import globalvar
  File "/Applications/", line 76, in <module>
    import wx
  File "/Applications/", line 45, in <module>
    from wx._core import *
  File "/Applications/", line 4, in <module>
    import _core_
ImportError: dlopen(/Applications/, 2): Library not loaded: /Library/Frameworks/UnixImageIO.framework/Versions/E/UnixImageIO
  Referenced from: /Applications/
  Reason: image not found
Error in GUI startup. If necessary, please
report this error to the GRASS developers.
Switching to text mode now.
Hit RETURN to continue...

dyld: Library not loaded: /Library/Frameworks/GDAL.framework/Versions/1.9/GDAL
  Referenced from: /Applications/
  Reason: image not found
/Applications/ line 635: 13465 Trace/BPT trap: 5       "$ETC/set_data"

[Opération terminée]

I don't know GRASS very well. So I do not know where to begin to look to solve these problems, any help would be great!

share|improve this question
What is your version of Mac OS X and have you installed the gdal framework ? (Library not loaded: /Library/Frameworks/GDAL.framework/Versions/1.9/GDAL) – gene Apr 10 '13 at 17:43
I have installed the gdal framework, it is in the applications folder, which I was wondering if it is simply in the wrong place? The OS is Lion 10.7.5. I am presuming that GDAL_Complete-1.9 is the same thing? Thanks! – Alexandra Apr 10 '13 at 17:51
Ahhh, got it, the application was not downloaded properly! Just opened it. Will be back on here again with another few questions no doubt! Thanks again. – Alexandra Apr 10 '13 at 17:57
GRASS in the application folder, the GDAL framework in /Library/Frameworks/GDAL.framework – gene Apr 10 '13 at 19:08

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.