Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I have a shape file of English wards from ONS.

It is similar to the files available here: http://www.ons.gov.uk/ons/guide-method/geography/products/census/spatial/2011/index.html except I had to explicitly ask them for ward shapes, for which they have just released census data.

They sent me a shapefile, and I would like a KML. The shapfile lines up perfectly (I use MapWindowGIS to view it) with The other shape files in that set, suggesting there is nothing wrong with the coordinates of this one file.

When I convert it to KML, all the coordinates are offset. I use Google Earth to view it, and it does not line up with the other KML files (for example MSOA).

In both cases I am looking at the clipped to the coastline versions. I am specifically looking at Lambeth, and I can see that the border does not line up with the Thames and is in land too far east and and possibly a bit too far south.

To convert from shapefile to kml I have tried postgis, a Shape2Earth plugin for map window GIS and an appplication called shp2kml. In all cases I get the same result.

I have tried converting the Shapefile from BNG to WGS84 then converting that to KML. I also tried converting to ETRS89, and then to WGS84 as suggested in one of the answers here:

Converting from British National Grid (27700) to WGS84 (4326) to Web Mercator (102100)

My prj file looks like this:

PROJCS["British_National_Grid",
GEOGCS["GCS_OSGB_1936",
    DATUM["D_OSGB_1936",
        SPHEROID["Airy_1830",6377563.396,299.3249646]
    ],
    PRIMEM["Greenwich",0.0],
    UNIT["Degree",0.0174532925199433]
],
PROJECTION["Transverse_Mercator"],
PARAMETER["False_Easting",400000.0],
PARAMETER["False_Northing",-100000.0],
PARAMETER["Central_Meridian",-2.0],
PARAMETER["Scale_Factor",0.999601272],
PARAMETER["Latitude_Of_Origin",49.0],
UNIT["Meter",1.0]
]

Any idea what I am doing wrong?

share|improve this question

2 Answers 2

up vote 2 down vote accepted

I think you are running into the OSGB36-reprojection shift as described here:

Raster incorrectly reprojected to OSGB(27700)

OSGB36 to WGS84 reprojection 'error'

There are a few reprojection methods around, with more ore less accuracy. I don't know what transformation MapWindowGIS uses. Late versions of QGIS and GDAL do it right by now.

share|improve this answer
    
Thanks, it looks like that was the problem. I installed Quantum GIS and the conversion looks okay now. Thanks a lot. –  zod Apr 11 '13 at 12:16

I have run into the same problem using QGIS today. Whilst I appreciate that it's late to answer I thought this might help.

My KML (WGS84) layers, which were exported from an OSGB (ESPG:27700) Shapefile were all offset to WSW by 3 - 5 Metres.

I managed to work around this by exporting to GeoJSON (WGS84) and then exporting the GeoJSON layer to KML format.

Hope this helps someone who, like me, comes across this question in their desperate Googling!

share|improve this answer
    
How did you work around it? Did you programmatically add/subtract 4 metres from every point? Or did the conversion to GeoJSON just work better? –  zod Dec 12 at 9:53
    
Hi Zod. Thankfully I didn't need to add/subtract at all. Just Save as>GeoJSON + WGS84. Then Save As>KML. This process still results in a 0.808mm shift to the SE - but I can live with >1mm! I don't know why conversion direct to KML produces this error. –  GOwen Dec 12 at 12:26
    
Have just done a bit more reading up. I wonder whether the projection transformation process differs when exporting to different file formats? A bit of interesting reading on the subject here: dragons8mycat.wordpress.com/2013/05/13/… –  GOwen Dec 12 at 15:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.