Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I encountered this error when trying to publish a map service to an ArcGIS Server 10.1 (installed on linux). enter image description here

--------------------------- Service Publishing Result --------------------------- Packaging succeeded, but publishing failed.

ERROR 001359: Failed to connect to the server.

Please consult the GP Results Window for enhanced error description


Other info: The geodatabase is registered with the server. And it did work in the past. We use a PostgreSQL gdb server.

Thank you for any help.

share|improve this question
Is there any more information in the Results window in ArcMap? – Alex Tereshenkov Apr 12 '13 at 18:42
In Results , the message is the same "Failed to connect to the server' – Ligia Apr 15 '13 at 6:31
OK. Do you have PublishingTools service running (under System folder in the Server connection)? I am not an expert on Linux, but could any security settings change their thus empeding ArcGIS connect to the Server? I am also interested to see what happens if you stage an .sd file (with the option to embed data), and then use ArcGIS Server Manager web application to publish .sd file as a service. Would it work? – Alex Tereshenkov Apr 15 '13 at 6:40

apparently in our case it was an IP problem. we changed the IP of our gis server a couple of days ago. and the gdb didn't recognized the new ip, so changed back to the old IP.

share|improve this answer

This just happened to me out of the blue and I checked a few things including those listed above. Nothing helped. Turns out it was failing because I had Characters on the layer names that it didn't like for example '+', '<', commas work fine.

share|improve this answer
I recently had the same issue. I came across… – arzola Jun 25 '15 at 12:53

So navigate to your server manager > services > Site root > publishing tools > edit service security > check (public,Available to everyone) > save.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.