Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I wonder if you can help me resolve a problem. I have given access to a WMS served up through Geoserver to various members of staff and it works fine on Arc 10 running on Windows XP. However I get an ArcMap drawing error when the WMS is called through Arc 10 running in a Windows 7 environment.

I get an ArcMAp Drawing Errors box appear with the following text within it:

One or more layers failed to draw: Geoserver Web Map Service: WMS service exceptions:Service Error Description: Rendering request would use 1328087KB, whilst the maximum memory allowed is 1000000KB

The dilemma I have is I'm not sure if this is a memory allocation problem with Windows 7, Arc or Geoserver seeing as it runs without problem on XP.

If it is Geoserver, I'm presuming I would need to increase the JAI Maximum Memory; how do I do that? The web isn't being very helpful I'm afraid.

Any help gratefully received,

Many thanks,

Red.

share|improve this question
    
Interesting question.. To increase JAI Maximum Memory please check that (docs.geoserver.org/latest/en/user/webadmin/server/…) and I am not getting this error at my end(using same configuration as you mentioned)..I will research and let you know..thanks –  Sunil Apr 15 '13 at 9:36
1  
The problem is due to geoserver, it is in the exception. Perhaps you have a higher resolution on your windows 7 computers causing the issue? –  johanvdw Apr 15 '13 at 9:43

1 Answer 1

GeoServer is simply refusing to answer a GetMap that would use too much memory compared to what it is setup to handle. These limits are there to avoid excessively large request, and can be tuned or disabled, see "maxRequestMemory" here: http://docs.geoserver.org/stable/en/user/services/wms/configuration.html

You can modify it in the "WMS" configuration panel in the GeoServer administration console.

share|improve this answer
    
Thanks for your help so far everyone! I have a meeting with one of our IS boys tomorrow. We have a whole section using this WMS but the problem only arises with Windows 7! I will let you know how we get on! –  Red Apr 23 '13 at 9:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.