Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a problem with QGIS 1.8 with OSGEO4W installer (windows 7 - 64 bit). QGIS crash on startup, it shows the splash screen and then nothing. I have updated from an old 1.7.4 QGIS version. I have done the same procedure in a portable computer and it works fine. The problem is only in the workstation. Is there a log file to view what is the problem? Thank you

share|improve this question
try unistall and reinstall. is your workstation old? perhaps it is not 64 bit or windows 7. – Ger Apr 17 '13 at 15:56
I have tried to uninstall and reinstall QGIS and then OSGEO4W completely, but the problem doesn't solve. My workstation is relatively new, 64 bit windows 7 service pack 1, I have just controlled in control panel. – Alessandro Battistini Apr 17 '13 at 16:06

Today i stumbled on the same problem (Win 7 64-bit, QGis 1.8.0). In search of a solution i disabled all plugins (in the registry), deleted the .qgis folder, Qgis registry entries and reinstalled, but nothing helped. However, i had QGis working just fine about a week or two ago. My QGis was crashing when the splash screen displayed "Starting python" (or something similar) and i remembered that i recently upgraded from Python 2.7.2 to 2.7.4.

So, i reinstalled python 2.7.2, changed environment variables to point to python 2.7.2 and now my QGis works again. Check your python version, you might have the same problem.

share|improve this answer
Great, the problem was this, thank you very much. I have disinstalled all version of python and purged every reference in register, and now QGis start again. Now I need only to reinstall Python 2.7.2. Thank again. – Alessandro Battistini Jun 19 '13 at 16:18
@AlessandroBattistini : I'm glad you got things sorted out :) I would be grateful if you marked my answer as the accepted solution, if it helped you out :) – Marko Jun 26 '13 at 10:54

You may have to delete your .qgis folder. Usually under c:\windows\users\. See also:

share|improve this answer
I have deleted .qgis folder in C:\Users\Alessandro. I have also tried to remove the registry key KEY_CURRENT_USER\Software\QuantumGIS. When I launch QGIS, it re-create the folder and the key but doesn't start. – Alessandro Battistini Apr 17 '13 at 18:55

I had a similar issue and I just solved the issue with Nathan W (a real Guru!). I had a file called path.txt in my c:\ and this caused QGIS-Dev build to fail (Lisboa worked fine though).

Just rename the file (c:\path.txt) if it exists. Also install OSGEO4W in admin.

See QGIS Dev install issues for details.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.