Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I'm using the Cut/Fill tool in 3d analyst to measure the volume of a feature, but I'm getting the following errors:

ERROR 010302: Unable to create the output raster: C:\Program Files (x86)\ArcGIS\Desktop10.0\bin\t_t495
ERROR 010067: Error in executing grid expression.
Failed to execute (CutFill).

I don't know where the output raster location listed in the error is coming from, since I'm specifying that the output should go into a file geodatabase that I've created (and the error's output location does not exist). Furthermore, this is a step in a script that has worked perfectly up until now, and I'm not sure what changed to make this tool suddenly throw these errors.

share|improve this question

closed as too localized by underdark Apr 20 '13 at 13:24

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Hi and welcome to GISse. With this type of a question, where there is an error involved, some additional detail is necessary. Since you state that you are providing an output location that does not match the location in the error, it indicates a potential error elsewhere in your script. It would really help in answering your question if you edit it to include the script that you have put together. –  Get Spatial Apr 19 '13 at 0:44
    
That's the thing, it isn't a problem with the script - I get the same error running Cut/Fill directly from the 3D analyst toolbox, using the appropriate script outputs. I have a raster layer clipped to the appropriate region, which goes into Cut/Fill with an associated surface interpolation, and both of those are File Geodatabase Raster Datasets which have been generated exactly as they should be. –  Donna Apr 19 '13 at 16:31
    
And, in a wholly unsatisfactory turn of events, it seems that it fixed itself; everything is magically working again, from the Cut/Fill tool to my entire script, even though nothing changed from yesterday. Thank you all for the suggestions, and for trying to help me with this! –  Donna Apr 19 '13 at 17:11

2 Answers 2

you have to give extension. Add .tif and try again.

share|improve this answer
    
So I tried this, and now I'm getting new errors: ERROR 999999: Error executing function. The table name is invalid. No spatial reference exists. ERROR 010029: Unable to create the raster C:\<correct path>.tif. ERROR 010067: Error in executing grid expression. Although previous uses of this function (when they were working, and without including a file extension) gave the output as File GeoDatabase Raster Datasets, within my assigned file GDB... –  Donna Apr 18 '13 at 22:44
    
then see above comment. you might not have permission to write. –  Naresh Apr 19 '13 at 9:00
    
well I am not a fan of arcgis. Works weird sometimes. I can recommend one more thing. Export your original raster to another file (just save it at another location/name). And then use that for input to your cut/fill. –  Naresh Apr 19 '13 at 9:03
    
Hmm. So that worked on the one test location that I've been using; I put all the inputs into the same geodatabase where the output was set to. And I just tried Cut/Fill again with the same locations I was using before (which generated the errors), and that actually worked as well. So it seems like maybe the problem fixed itself overnight... –  Donna Apr 19 '13 at 16:46

Maybe you don't have permission to set output to the C Drive . do you try change output path to another Drive?

share|improve this answer
    
That's the problem; the output path isn't supposed to be in C:\, it's supposed to go in a different drive where all of my data is stored - and where I definitely have write permissions. I'm not sure where ArcGIS is getting that C:\ path from. –  Donna Apr 19 '13 at 16:34
    
@ِDonna do you have any folder name other than English language in output path ? or the output path is very long? for example : c:\m\n\g\h\m\b\ –  wetland Apr 19 '13 at 16:49
    
See below...I'm still not sure what was going wrong, but it's putting my outputs in the right place again. –  Donna Apr 19 '13 at 17:13

Not the answer you're looking for? Browse other questions tagged or ask your own question.