Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I have gwc layer on my Geoserver.
Now i want print this layer using Geoserver print module but dont know how to do this.
When i try wms layer all works fine. But how to print gwc layer?

MORE INFO

In cliet side i have a gxp and try to print using gxp_print plugin. My problem in that i cant set url to gwc layer.
I read this and this: so i try this url:

layer.setUrl("/geoserver/gwc/service/wms?BBOX=7637927.0361051%2C6845332.4516735%2C7750900.9638949%2C6971453.5483265&HEIGHT=256&
WIDTH=256&TRANSPARENT=true&map_resolution=305.74811309814453&VERSION=1.1.1&
FORMAT=image%2Fpng&TILED=true&SERVICE=WMS&format_options=dpi%3A100&LAYERS=gisurfo:atd&
REQUEST=GetMap&STYLES=&SRS=EPSG%3A900913");

But geoserver return me error:

400: Requested horizontal resolution: 441.30440542890574 , best match: 
305.74811309814453 exceeds 10% threshold. Perhaps the client is configured with an 
incorrect set of scales (resolutions), or the DPI setting is off compared to the one in GWC ?

This same like in links above. So how to print gwc?

UPDATE

Good news. I change scales in my config.yaml file to scales what i get from gwc layer (but i get only left part of each scale). Now i try to print gwc layer but it not printing. In Geosrever log i found Bad Request:

java.io.IOException: Error (status=400) while reading the image from 
http://geourfo.ru:9091/geoserver/gwc/service/wms?BBOX=6866019.0%2C7636631.0%2C6950767.0%2C7752196.5
&HEIGHT=625&WIDTH=458&VERSION=1.1.1&FORMAT=image%2Fpng&SERVICE=WMS&
format_options=dpi%3A75&LAYERS=gisurfo%3Aatd&REQUEST=GetMap&STYLES=&SRS=EPSG%3A900913
: Bad Request

After i change width and height to 256/256 and get my tile!
So question: why iprint plugin take tiles with HEIGHT=625 and WIDTH=458 but not with 256x256?

share|improve this question
    
Any solution so far? I´m going throught the same problem at the moment –  CarlosRodLop Apr 30 '13 at 12:00
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.