Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a simple SLD style using in GeoServer v2.3.0 and testing in uDig. I have a interstate symbol that I do not want the label symbol to follow the line. I thought if I set:

<sld:VendorOption name="followLine">false</sld:VendorOption>

It would ignore this parameter.

enter image description here

How do I make my labels ignore followline?

share|improve this question
what happens if you remove the line completely? – iant Apr 22 '13 at 14:20
@iant, Same result (I'm testing it within uDig). – artwork21 Apr 22 '13 at 14:25
Did you ever figure out a solution for this? – mbosecke Feb 12 at 20:39
@mbosecke, yes I did not use any vendor options just the x and y anchor points. – artwork21 Feb 13 at 3:53
Thanks! For me it turns out it was the "PerpendicularOffset" that was triggering the labels to follow the line (which makes sense). Removing this offset fixed it for me. – mbosecke Feb 16 at 16:57

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.