Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I georeference a map of vegetation types (about 20 colours, each representing a certain vegetation) the quality of the georeferenced map is really bad and some colours have changed (e.g. black becomes white), which makes it almost impossible to recognise certain types.

I did the "usual" procedure: transformation type: linear, method: nearest neighbor. For source I tried jpeg & tiff, same bad result.

Any suggestions how to improve the quality of the map and the originality of the map?

Thanks!

share|improve this question
    
I don't know about QGIS, but ArcMap often defaults to a "standard deviations" stretched colour ramp when you add a newly georeferenced image. This often distorts the colours, although your example sounds pretty extreme. The solution in ArcMap is to set the 'stretch type' from Standard deviations to None. Perhaps the same applies in QGIS? – JamesS Apr 29 '13 at 11:07
    
Thanks a lot for your response, but i does not work. However I just got the shape, so problem avoided. – user16032 Apr 29 '13 at 16:04

Kind of an old thread, but for an extra $.02, I solved this problem by ensuring the Limits (minimum/maximum) setting was set to "Minimum/maximum" in the Rasters section of the Rendering tab of QGIS settings. Also, in the same settings area, the Green Band setting was set to 0 when I initially came across the problem so I set it to 2. May also want to play around with the Raster properties as well.

share|improve this answer

This problem may arise if the source file has paletted colours.

During reprojection, QGIS tries to interpolate between original cell values, and this fails when you only have a bunch of paletted colours.

So expand your raster file to RGB, which allws for contiguos interpolating.

Raster -> Convert -> Translate has a dropdown box that you can change frm grey to RGB.

Or use gdal_translate -expand rgb directly.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.