Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

When I try to load a WMS layer which has a WSG84 as a default projection and use a CRS transformation on it, it gives this error message:

Request contains a format not offered by the server.
The WMS vendor also reported: 
Parameter 'width' contains unacceptable value.

The default projection I use for my project is S-JTSK Krovak (Greenwich) projection with WGS84 correction:

+proj=krovak +lat_0=49.5 +lon_0=24.83333333333333 +alpha=30.28813972222222 
+k=0.9999 +x_0=0 +y_0=0 +ellps=bessel +pm=greenwich +units=m +no_defs 
+towgs84=570.8,85.7,462.8,4.998,1.587,5.261,3.56

At a zoomed-out view (whole Czech Republic displayed), it displays correctly, but when I zoom in, the error above occures and the layer fails to display. Any advise on what should I do? Also, the WMS layer I use is http://geoportal.gov.cz/arcgis/services/CENIA/cenia_rt_II_vojenske_mapovani/MapServer/WMSServer

Thanks.

share|improve this question
add comment

1 Answer 1

The WMS layers load here using Ubuntu Master. Add the layer, which gives you the country overview, then right-click on the layer and set the project CRS from the layer CRS. This will set the project CRS to EPSG:102067 and allows zooming-in to large scales.

You could make a custom CRS for the project using the Proj string you posted, which might improve accuracy. It might be a good idea to move the "+no_defs" parameter to the end of the string.

N.

share|improve this answer
    
Well, the problem is that setting both the project CRS and layer CRS to Krovak transformation makes the WMS layer output distorted, as if no transformation was used (hence as if the WMS was just in WGS84). Only if I set the layer CRS to WGS84 and project CRS to Krovak, the map is shown correctly in smaller scales, but produces the error above in larger scales. Also, a hint could be that at smaller scales, when the whole country is shown, QGIS reports ridiculous scales, like 1:24 for whole country. –  Rajcze May 2 '13 at 20:48
    
Okay, one of the CRSs you can select when loading the layer is WGS84/UTM 33N (EPSG:32633). As a test, load the WMS layer using this CRS, then set the project CRS to EPSG:32633 and disable on-the-fly CRS tranformation. Then try zooming-in to see what happens. –  nhopton May 3 '13 at 8:55
    
Just as distorted as with both CRS set to Krovak. This way our country looks in plain WGS84. –  Rajcze May 3 '13 at 10:49
    
Which version of QGIS and which OS are you using? As I mentioned, there are no problems here with Master running under Ubuntu. N. –  nhopton May 3 '13 at 12:53
1  
Heureka! Finally got it working. Not a clue how however =D All I did was adding a new WMS layer with CRS EPSG:32633 and setting the project CRS to the custom projection with the code above just after I added the layer. After that point, all the WMS layers were working just fine when I set their CRS to EPSG:32633. So, thanks a lot, at least I gained some insight on how the layers work =D –  Rajcze May 3 '13 at 21:44
show 5 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.