Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I am running an instance of Ubuntu Server 12.04 on AWS and after installing the OpenGeo suite have been unable to get access to tomcat6 via localhost:8080 and thus no access to the OpenGeo dashboard.

What I have tried so far: allowed access to port 8080 in AWS, disabled the firewall locally, reinstalled OpenGeo numerous times, and used netstat to see that tomcat is not listening. I have installed Apache and it does listen to port 80.

What is interesting is that I can access tomcat when installed without the OpenGeo suite but once I install the suite I can no longer access it. I am a Linux newbie and at a loss. If necessary, please let me know which logs would be helpful to post. Thanks.

Update: Well no luck after almost two weeks of trying. I have come to the conclusion that OpenGeo/OpenPlans intentionally cripples the Community edition of OpenGeo Suite on Amazon-EC2 in order to sell their packaged for a fee version. Fair enough but I can't afford to pay them and Amazon while I learn.

Update 2: Solved (thank you Don Meltz). Because of the limited memory available in a micro-instance a swap file must be created for tomcat to work. My apologies to OpenGeo. I hope this helps someone else with this problem.

share|improve this question
1  
The only difference between the Community Edition and the Enterprise Edition of Suite is that Enterprise adds a few extra plugins. Crippling the Community Suite in any way would be completely counter productive as the point is really to sell support contracts, not the software itself, and the software is available for free piecemeal anyway. –  smithkm May 10 '13 at 18:00
    
I understand your point and appreciate your comment as you seem knowledgeable on the subject. Do you have any idea as to why the Community Edition of the OpenGeo Suite will not install correctly on Amazon-EC2? It seems that certain WAR files are not installed (blocked?) compared to my vm version of Ubuntu Server 12.10 running locally. Any input is appreciated. –  Matt May 11 '13 at 1:34
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.