Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I'm using MapInfo 11.0.4 Release Build 404

Whenever I want to save a workspace file in the MapInfo workspace format (*.mws) it saves the file as expected and with the right file extension. However, when I look at the content of the file in a text viewer, I can see that it is a .wor file in reality. It's not saving with the XML format that should be in a *.mws file.

Since there is no other way to save workspace I cannot create the MWS format at all and I need it to use with the MapInfo Spacial Server product.

Any help would be appreciated.

share|improve this question

2 Answers 2

I just tried this with my MapInfo Professional 11.0.4, and I was able to save it as a "true" MWS, the XML version of our workspace.

Just to make sure: You do change the file type when you use Save workspace, right?

Also is it a very "complicated" workspace, that you are saving? Could you try with a very basic one? Just one table in a map window. Does that work?

Can you try this:

  1. Open your tables in the window
  2. Open the MapBasic window (from the Options menu)
  3. Paste this statement into the MapBasic window (change the path to one that fits your requirement

    Save MWS Window (FrontWindow()) Default FrontWindow() As "C:\Test.mws"

  4. Place the cursor somewhere in the line you pasted and hit the Enter key

Now have a look at the file created

share|improve this answer
    
I change the file type in the "Save as type:" box under the file name to the *.mws format. –  jmbouffard May 6 '13 at 12:39
    
The project I tried to save cannot be more basic that that: 2 simple map layers and that's it. –  jmbouffard May 6 '13 at 12:41
    
Try this next option that I have added to the description above –  Peter Horsbøll Møller May 6 '13 at 14:38
    
Thanks a lot for your help but I just found my problem. It was related to a MapBasic application that I have in my MapInfo that was running code when saving a workspace. After I disabled this application it was working fine. –  jmbouffard May 6 '13 at 18:06
    
Ah, yeah that can be tricky if your applications embed themself in that way –  Peter Horsbøll Møller May 7 '13 at 11:46
up vote 0 down vote accepted

The issue was related to a MapBasic application that was running inside MapInfo. This application was automatically executing some code when saving a workspace. After disabling this MapBasic application I was able to save *.mws files.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.