Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

When I try to calculate a field nothing happens. I have always been able to just select the field, open the field calculator and type = and the new number. This is frustrating because the other GIS person can do it with no problem. I've tried several different tables, numeric and string fields. I don't know Python and shouldn't need to use it just to change a field of numbers to a different number. I have uninstalled ArcGis 10 and reinstalled it and SP1.

Thanks

share|improve this question
4  
In most languages that initial "=" should produce a syntax error. –  whuber Feb 9 '11 at 22:02
    
What whuber said. Try typing just the number, it should work so long as it's a numeric (long, float, double, etc.) field type. –  blah238 Feb 9 '11 at 22:13
    
Mtrombley--you said you got a solution. Can you post it? –  James Schek Feb 12 '11 at 7:19
add comment

4 Answers

Don't know if this applies to your situation, but there's a known bug in ArcGIS 10 when using a personal geodatabase (.mdb). If you use the field calculator, at least in an edit session, you have to save the edits on each field before you can use FC on another field. Very annoying.

share|improve this answer
    
Thanks - but this is a problem with shapefiles too. I just can't seem to get the field calculator to work. Been checking ESRI for help but none yet. –  user1919 Feb 9 '11 at 20:36
    
Mine works but only after sitting for about 2-3 mins –  Brad Nesom Feb 9 '11 at 20:54
    
Mine looks like it is working then stops and nothing changes in the field. –  user1919 Feb 10 '11 at 16:50
    
Ithe problem is now fixed. I finally asked ESRI support and they helped me. Thanks so much to all that made suggestions. –  user1919 Feb 11 '11 at 15:44
1  
It's been a year since this was last commented on, but I just ran into the same problem with the Field Calculator acting on a Shapefile. At first, nothing happened, and I finally realized that I needed to start an editing session first. Then it did work, only to obliterate all the values upon closing the editing session (with Save Changes). So I take it this has still not been dealt with. –  mvexel Apr 23 '12 at 5:52
show 1 more comment

I had this problem too. I was using fields to calculate the value. Turned out that it didn't work with VB. Had to change to Python (and use ! by the Field names : !Field!)

share|improve this answer
add comment

I've run into issues with the Field Calculator not working as expected in ArcGIS 10 SP2 if your layer contains forward slashes in its name. For ex. if you name a layer "Parcels 9/14/11" you'll get an error message. Remove the slashes and it'll work. Figured this out through trial and error. Good luck!

share|improve this answer
add comment

Because layer names double as SQL table names, you should never use punctuation besides underscores. Don't begin them with numbers, either, or use spaces.

-- Andy

share|improve this answer
add comment

protected by whuber Jun 13 '13 at 13:09

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?