Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

am trying to use geoserver 2.2.5 with tomcat 7.0.34 following this tuto: http://ian01.geog.psu.edu/geoserver_docs/software/geoserver.html but am getting this error concerning the servlet jar:

     5 mai 2013 14:10:25 org.apache.catalina.core.StandardEngine startInternal
     INFO: Starting Servlet Engine: Apache Tomcat/7.0.34
     5 mai 2013 14:10:25 org.apache.catalina.startup.HostConfig deployWAR
     INFO: Déploiement de l'archive C:\Users\OUK\Desktop\PFE\tomcat-7.0.34\apache-tomcat-7.0.34\webapps\geoserver.war de l'application web
     5 mai 2013 14:10:26 org.apache.catalina.loader.WebappClassLoader validateJarFile
     INFO: validateJarFile(C:\Users\OUK\Desktop\PFE\tomcat-7.0.34\apache-tomcat-7.0.34\webapps\geoserver\WEB-INF\lib\servlet-api-2.5.jar) - jar not loaded. See Servlet Spec 2.3, section 9.7.2. Offending class: javax/servlet/Servlet.class
     log4j:WARN File option not set for appender [geoserverlogfile].
     log4j:WARN Are you using FileAppender instead of ConsoleAppender?
     05 mai 14:10:35 WARN [config.CustomEditorConfigurer] - Passing PropertyEditor instances into CustomEditorConfigurer is deprecated: use PropertyEditorRegistrars or PropertyEditor class names instead. Offending key [org.geotools.util.Version; offending editor instance: org.geoserver.platform.util.VersionPropertyEditor@126456a
     5 mai 2013 14:10:35 org.geoserver.platform.GeoServerExtensions checkContext
     GRAVE: Extension lookup occured, but ApplicationContext is unset.
     05 mai 14:10:35 ERROR [geoserver.global] - 

can anyone figure out how to solve this problem, thnks.

share|improve this question
    
i added this balise to my pom file: <dependency> <groupId>javax.servlet</groupId> <artifactId>javax.servlet-api</artifactId> <version>${project.version}</version> <scope>provided</scope> </dependency> but still the same error –  Asma.O May 5 '13 at 14:03
add comment

2 Answers

This has nothing to do with the servlet-api-2.5.jar (note that the message that refers to this file is an INFO message not an error message). If you want to stop that message appearing just delete the file.

The problem starts with this message:

5 mai 2013 14:10:35 org.geoserver.platform.GeoServerExtensions checkContext GRAVE: Extension lookup occured, but ApplicationContext is unset.

You need to figure out what is causing this error message and fix that.

share|improve this answer
add comment

set environment in system variables

variable name : CLASSPATH

variable value : C:\apache-tomcat\lib\servlet-api.jar

share|improve this answer
    
i tried it but it doesn't work :s :s the brower don't recognize the page <localhost:8080/geoserver>; –  Asma.O May 5 '13 at 18:27
    
I think Apache tomcat is not running. –  chingchai May 6 '13 at 7:28
    
no it's working when i navigate to localhost:8080 i get home page of apache –  Asma.O May 6 '13 at 10:16
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.