Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I have some trouble in running saga and grass algorithms in sextante. When I double click it appears a pop-up saying:

Missing dependency.This algorithm cannot be run :-( This algorithm requires SAGA to be run.Unfortunately, it seems that SAGA is not installed in your system, or it is not correctly configured to be used from QGIS Click here to know more about how to install and configure SAGA to be used with SEXTANTE

I read the documentation, but i didn't understand what I have to do.

share|improve this question

2 Answers 2

up vote 3 down vote accepted

Isn't it obvious that you need to install SAGA first? If SAGA is installed check in SEXTANTE settings if it is activated. Install python-saga module. Also check out this post on setup SEXTANTE for Ubuntu.

If none of this helps the reason may be that SEXTANTE is looking for SAGA modules in the wrong directory. The default path to SAGA algorithms is /usr/lib/saga and many applications expect to find it there. So you may just create symbolic link to the installed modules (that are in /usr/lib64/saga for example, but you will need to provide the pass that is correct in your case):

:~> sudo ln -s /usr/lib64/saga /usr/lib/saga
share|improve this answer
    
That obvious that I need to install saga first, and I installed it a few months ago.. I watched and all the saga libraries are in the usr/lib/saga folder. So what is the path for the link I have to create? –  matteo May 7 '13 at 9:11
    
@matteo, in this case there is no need for symbolic link. Just reinstall SAGA, python-saga and then SEXTANTE (as it is described in article I gave a link to). BTW, what steps were suggested by the module itself and you failed to implement? is SAGA working? –  SS_Rebelious May 7 '13 at 9:32
    
I reinstall Saga and then sextante and now it seems that all is working. Thanks!!! –  matteo May 7 '13 at 13:06
    
@matteo, I'm glad I was able to help. Please consider accepting my answer so your questions will be removed from 'unanswered' section. –  SS_Rebelious May 7 '13 at 15:31

In QGIS in "Processing" options, select "Options and configuration", SAGA and uncheck the option "Enable SAGA 2.0.8..." I'm working in ubuntu 12.04 and with SAGA 2.1.1

share|improve this answer
    
this solved the problem for me with QGIS 2.2 on ubuntu 12.04. –  jirikadlec2 May 13 at 8:19
    
Also had to do this for QGIS 2.4 on Ubuntu 14.04 –  Spießbürger Jul 8 at 21:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.