Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

how can i add a layer upload panel tool in my suite sdk? The main problem is when i click "upload layers" button. Appear errors in the firebug. I don't know the reason why those errors appear

TypeError:b[e] is not a constructor... TypeError:this.dataStore is undefined:this.dataStore.emptyText = this.dataStoreEmptyText; (in LayerUploadPanel.js line 327).

i'm not sure if i haven't added the necessary code to app.js. i want to upload mi own shapes from layeruploadpanel, but i don't how to do it. Anyone could help me please?

share|improve this question
    
Welcome to GIS-SE! Would you be able to edit the title of your question so that it becomes a "short sentence question" rather than just a "single word statement", please? –  PolyGeo May 7 '13 at 11:24

1 Answer 1

up vote 1 down vote accepted

The LayerUploadPanel has a dependency on FileUploadField.js. To satisfy this dependency, copy FileUploadField.js to your app directory, and add

@require FileUploadField.js

at the top of your app.js file.

share|improve this answer
    
thanks for answering so quickly, Andreas. That was exactly the problem, but it appeared another one. I can't upload the map with the files .shp .shx .prj .dbf; then appears that message: (!) "source cities.zip is INCOMPLETE". I have tried several times with different files, but it always appears the same message. I can't solve it on my own. Thank you for helping. Álvaro –  user17918 May 8 '13 at 12:40
    
You can go to the GeoServer Importer UI to see why the source is incomplete. I seem to remember that this can happen when GeoServer does not recognize a PRJ file. –  ahocevar May 9 '13 at 20:53
    
It is possible, but I have tried upload other maps as nyc_roads.zip and this is uploaded perfectly into my suite and into suite.opengeo.org/geoexplorer/composer but, for example medford_citylimits is uploaded into the composer, but not into my suite. Always appears the next failure "cities.zip is INCOMPLETE", but if I try upload the zip without the file .prj, appears "cities.shp is INCOMPLETE". –  user17918 May 14 '13 at 11:49
    
On the Geoserver Importer UI appear these failures: org.apache.wicket.WicketRuntimeException: Exception in rendering component: [MarkupContainer [Component id = kml.regionateAttribute]] at org.apache.wicket.Component.renderComponent(Component.java:2725) at org.apache.wicket.MarkupContainer.onRender(MarkupContainer.java:1538)...... I thought that it would be a failure, because of the kind of projection EPGS:4326, but it doen't meanto be that. Could be by anything written in the .prj, and the way geoserver has of managing that? –  user17918 May 14 '13 at 11:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.