Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I am working with GPX data. I imported them to ArcGIS by 'GPX to feature' and then I created lines from these points. I am trying to smooth (or simplify) the lines now, but the tools 'smooth line' and 'simplify line' are not working. (Maybe it is because of the big amount of points..)

Do you know any tools or hints how to smooth these lines created from GPX?

Thank you for your answers

share|improve this question
1  
Have you been trying the Generalize and Smooth tools from the Advanced Editing toolbar or something from the toolbox? How many vertices on a line are you calling a "big amount"? –  PolyGeo May 9 '13 at 21:15
    
Yes I tried these too... and they weren't working too (I tried different line input and that worked so there shouldn't be anything wrong with the tools). There is usually one vertex per 10m and my extent is approximately 10 x 10 km (is this description understandable and helpful?) –  Mary May 9 '13 at 21:34
    
What do you mean by "weren't working"? Did they perhaps give an error message, do nothing or give a poor result? If you want to count the number of vertices there is a Count Vertices tool available. –  PolyGeo May 9 '13 at 21:54
    
Dear 'PolyGeo' I have to apologize that you spent time trying to help me. I am totally stupid :D and I solve my problem like 5 minutes ago :D I was about to write you that I used the tool that you've recommended and that it gives me strange results (2 everywhere) however when I think about my answer I realized that I have totally forgot that I used 'split line on vertices tool'few weeks ago. Which obviously split my line in thousands small lines containing only 2 (starting and ending) vertices which cant be smoothed. But thank you very much, because I wouldn't realize this without you :) –  Mary May 14 '13 at 16:57
    
No need to apologise - I'll write up our troubleshooting steps as an Answer so that they help point the next person with the same symptoms toward a quicker solution. –  PolyGeo May 14 '13 at 22:01

1 Answer 1

up vote 0 down vote accepted

As emerged from our Comments the troubleshooting steps which led to resolving this were:

  • Were the Generalize and Smooth tools from the Advanced Editing toolbar being used?

They were.

  • How many vertices did the line which was failing to smooth/generalise have?

The Count Vertices tool was downloaded to do the count and then it became evident that the "line" was actually many single segment lines that had been created from a 'split line on vertices tool". Lines with only two vertices cannot be smoothed/generalized further.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.