Sign up ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I have a problem involving the import vector data command, specifically importing shape files. I installed QGIS on a pc at work and there I could import shape files into GRASS GIS 6.4.3RC2 (which is installed along with QGIS) and then export them as .DXF but it took a lot of time to do that so I wanted to finish on my pc at home which is much better than those at the office. I downloaded QGIS again at home and made the same steps as at work but now GRASS wont import the same shapefiles... This is what the program tells me:

Traceback (most recent call last):
  File "C:\PROGRA~2\QUANTU~1\apps\Python27\lib\site-
line 140, in OnChanged

  File "C:\PROGRA~2\QUANTU~1\apps\grass\grass-6.4.3RC2\etc\w
xpython\gui_core\", line 1601, in OnSetDsn

  File "C:\PROGRA~2\QUANTU~1\apps\grass\grass-6.4.3RC2\etc\w
xpython\gui_core\", line 1620, in _reloadLayers

dsn = dsn)
  File "C:\PROGRA~2\QUANTU~1\apps\grass\grass-6.4.3RC2\etc\w
xpython\core\", line 660, in RunCommand

ps = grass.start_command(GetRealCmd(prog), flags, overwrite,
quiet, verbose, **kwargs)
  File "C:\PROGRA~2\QUANTU~1\apps\grass\grass-6.4.3RC2\etc\p
ython\grass\script\", line 177, in start_command

return Popen(args, **popts)
  File "C:\PROGRA~2\QUANTU~1\apps\grass\grass-6.4.3RC2\etc\p
ython\grass\script\", line 56, in __init__

startupinfo, creationflags)
"C:\PROGRA~2\QUANTU~1\apps\Python27\lib\", line
679, in __init__

errread, errwrite)
"C:\PROGRA~2\QUANTU~1\apps\Python27\lib\", line
867, in _execute_child

args = '{} /c "{}"'.format (comspec, args)
'ascii' codec can't encode character u'\xfc' in position 43:
ordinal not in range(128)

can anyone help me here?!

Thank you for your help

share|improve this question
Could you try recent RC3 release rather than using QGIS's version?. you can download wingrass from here – rashad May 11 '13 at 5:55
Do you have some non-ascii characters in the path to the shapefile?? – Micha May 11 '13 at 15:02
thanks four your answers. But I still can't import any shapefiles... I installed the version you suggested but it did not work. I don't think I have any non-ascii characters in the path. This is the path X:\kirchen\Daten für PVD\30ziger Biotope BNatSchG\Shape – user18044 May 11 '13 at 21:01
The "ü" in "für" may cause troubles? Just guessing... – markusN May 11 '13 at 21:33

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.