Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I have following problem. After upgrade to 13.04 I had problem with PyQGIS mentioned here.

I followed almost all advices described there, finally removed QGIS (had 1.8 Lisboa) and added the Ubuntugis repository again:

$ sudo apt-add-repository ppa:ubuntugis/ubuntugis-unstable
$ sudo apt-get update
$ sudo apt-get install qgis

But still have problem with broken dependencies:

Následující balíky mají nesplněné závislosti:
 qgis : Závisí na: qgis-common (= 1.7.4+1.7.5~20120320-1.1) ale 1.8.0-1~quantal3 se bude instalovat
        Doporučuje: qgis-plugin-grass ale nebude se instalovat
        Doporučuje: python-qgis ale nebude se instalovat
E: Nelze opravit problémy, některé balíky držíte v porouchaném stavu.

in English:

The following packages have broken dependencies:
      qgis: Depends on: qgis-common (= 1.7.4 +1.7.5 ~ 20120320-1.1) but 1.8.0-1 ~ quantal3 will be installed
             Recommended: qgis-plugin-grass but will not install
             Recommended: python-qgis but will not install
     E: Unable to correct problems, some packages you have in damaged state.

However I cannot fix it. I do not need Grass, but qgis-common seems to be important.

Any idea what I could do?

thanks

share|improve this question
    
Looks like the quantal version is to be loaded, not the raring version you need. –  Andre Joost May 10 '13 at 12:40
    
For raring there is only 1.7 version in official repository launchpad.net/ubuntu/+source/qgis and Ubuntugis also does not have it: launchpad.net/~ubuntugis/+archive/ubuntugis-unstable/… –  Juhele May 10 '13 at 12:51
    
This page tells me it is 1.8.0: qgis.org/debian/dists/raring/main/binary-amd64/Packages. The official Ubuntu repo is outdated, thats true. –  Andre Joost May 10 '13 at 17:38
add comment

4 Answers

up vote 5 down vote accepted

Ok, although it is funny to answer my own question I think it might be useful also for other QGIS users.

If you go to Muon Package Manager and in Software sources remove all QGIS related repositories like Ubuntugis etc. then you add these (obtained from QGIS website):

deb     http://qgis.org/debian-nightly raring main
deb-src http://qgis.org/debian-nightly raring main

After updating package information (just restart Muon) you can update or completely install new QGIS. In my case it was version 1.9 Alpha so I am not sure how stable it will be...

maybe there is also another solution but just wanted to let you know :-)

share|improve this answer
2  
It's fine for someone to answer their own question, for exactly the reason you stated (helping others). I suggest that you also mark this as the accepted one. –  user3461 May 10 '13 at 13:26
    
Following the official QGIS page hub.qgis.org/projects/quantum-gis/wiki/Download#26-Ubuntu, it should be deb http://qgis.org/debian raring main deb-src http://qgis.org/debian raring main –  Andre Joost May 10 '13 at 17:40
    
Andre: for this repo I am getting: /var/cache/apt/archives/python-qgis_1.8.0-1~raring1_i386.deb trying to overwrite '/usr/lib/python2.7/dist-packages/pyspatialite/_spatialite.so', which is also in package python-pyspatialite 3.0.1-2 error message on my other machine... –  Juhele May 10 '13 at 21:42
add comment

Already you find some answer. An other solution maybe can be to type after "sudo apt-get update" still "sudo apt-get upgrade" and then to install QGIS

share|improve this answer
    
in my case these unluckily did not work :-( –  Juhele May 10 '13 at 16:38
add comment

There's very little in the ubuntugis-unstable ppa for 13.04 yet, currently just proj and geos. What I did in synaptic (or muon), was edit the ppa and change the distribution name from raring to quantal. Worked fine.

share|improve this answer
add comment

I couldn't make those solutions work, but a quick google search turned up this option http://qgismalaysia.blogspot.com/2013/04/ubuntu-1304-and-qgis.html.

It installs the master version, the instructions are step by step so I won't go through them here. Anyway, it worked for me.

share|improve this answer
    
yes, I finally used also the master and went back to 1.8. Had to perform a big cleanup and completely remove QGIS first. –  Juhele May 31 '13 at 8:19
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.