Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I published a service to ArcGIS Server 10.1 from an .mxd with no halos around the labels and created a flex application using the flex viewer. When I browse to the map here and zoom in on an individual trail segment, the labels become very grainy and appear to have a white halo around them, making them very difficult to read. It becomes exceptionally noticeable when imagery is used as a basemap.

Is there any thing I can do to stop the labels from getting all messy looking or is this just how they look when using flex?

share|improve this question
    
Do you have anti-aliasing turned on for your features in your map service? –  Nick Ochoski May 15 '13 at 22:18
    
My Anti-Aliasing settings are as follows: Anti-Aliasing = none Text Anti-Aliasing=forced I tried changing these settings, clearing my browser cache, and revisiting the map but no luck on fixing it. –  cl3 May 16 '13 at 13:43

4 Answers 4

up vote 1 down vote accepted

Stick to standard web fonts. I've had luck with using Verdana black with white halos, if you want the halos. But it appears you do not.

share|improve this answer

I know this is an old question, but wanted to share that I fixed this problem by caching my services using PNG32 format instead of PNG8. I had tried changing my fonts prior to that and that didn't help.

share|improve this answer

Be sure to be using the standard label engine and not Maplex. Maplex doesn't work well with ArcGIS services.

share|improve this answer

I turned out to be a simple change of font that fixed my problem.

share|improve this answer
    
This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post - you can always comment on your own posts, and once you have sufficient reputation you will be able to comment on any post. –  Fezter May 23 '13 at 20:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.