Sign up ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I need to establish a model of maritime pollution and I try to use the grid option to work on ocean sectors. I tried to use my grid on a vector file, .shp, with points. Each point is a maritime pollution fact.

Tried with the native Grid (vector) option in QGIS: give me an error

Tried with the Qmarxan plugin (seems to be the one i need): give me an error

Is it a problem with Python, my layer, my data or a bug problem? I tested Qmarxan with a Geotiff, and it worked quite well. But it seems possible to use it with a vector layer (

The error with Qmarxan :

Traceback (most recent call last):
  File "C:/Users/GF/.qgis//python/plugins\Qmarxan\", line 189, in accept
    self.writeFile(boundBox, sideLen, hexagon)
  File "C:/Users/GF/.qgis//python/plugins\Qmarxan\", line 333, in writeFile
ZeroDivisionError: integer division or modulo by zero

Version de Python :
2.7.3 (default, Apr 10 2012, 23:31:26) [MSC v.1500 32 bit (Intel)]
share|improve this question

closed as unclear what you're asking by PolyGeo Jan 28 at 0:34

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question.If this question can be reworded to fit the rules in the help center, please edit the question.

Which steps exactly did you use with what you call the "native grid option"? Which error do you get? – underdark May 24 '13 at 11:26

Browse other questions tagged or ask your own question.