Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I am trying to find points that fall within a polygon. Both layers are vector ESRI shapefiles. I used the fTools based intersect under Vector>GeoprocessingTools>Intersect. The output is an empty shapefile and I get the following warning:

Warnings: Feature geometry error: One or more output features ignored due to invalid geometry. Some output geometries may be missing or invalid.

I first tried this with layer of ~519 points and a complex polygon layer outline of the city limits of a city. I then made a new shapefile with just 6 points with some inside and some outside a polygon in a separate layer that I also drew. I got similar results. With this error:

Warnings:

Feature geometry error: One or more output features ignored due to invalid geometry. Some output geometries may be missing or invalid.

I used the geometry check tool to check both layers and got no errors.

If I use the same two simple layers and clip the point layer with the polygon layer I get what I want (i.e. all the points that fall within the polygon but not those outside the polygon). If I use the spatial query tool (Vector>SpatialQuery) I get the results I want as a selection.

In my original use and with the simple polygons, both shapefiles share the same CRS.

My question is, am I misunderstanding what the Geoprocessing tool Intercept does or am I missing some requirement of this tool or is it just working incorrectly?

City Limits Polygon City Limits Polygon with Points Used in Intersect Simple Polygon and Points

share|improve this question
    
The complex polygon seems to be broken. Can you share the data or at least a screenshot? –  underdark May 28 '13 at 11:10
    
Added images the first two of the complex polygon and the complex polygon with the points used in the intersect operation. The third image is of the simple polygon and point shapefiles I made and got the same result (an empty shapefile) when intersecting them. –  earthstephen May 28 '13 at 17:31
    
If you just need a spatial subset of your point-layer, why not use the SpatialQuery tool to first select all intersecting points and then save them as separate layer? –  Curlew May 28 '13 at 17:41
    
@Curlew That is actually what I ended up doing and it works but I guess the core of my question is why doesn't Vector>GeoprocessingTools>Intersect give me the same results? Is there some difference in the definition of Intercept between the two? I have since discovered that when using Vector>GeoprocessingTools>Intersect for two polygon layers I get the results I expect (i.e. a polygon that is the overlapping portion of the two input polygons). Does this tool not work with point/poly intercepts? That would be good to know for future work. –  earthstephen May 28 '13 at 20:10
    
I think "Intersection" as such is mainly used for intersecting two polygon layers as displayed in the ESRI resource files (tinyurl.com/qxnx4pz). Back when i took ArcGis courses everybody told me that intersection is about polygon-polygon interaction so i assume that you can't use it for points. But i may be mistaken –  Curlew May 29 '13 at 18:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.