Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I have Geoserver 2.2-SNAPSHOT installed on Ubuntu Server 10.04 as a VirtualBox guest on a Windows 7 host. This is part of a larger OpenGeo installation. I am trying to create a new SQL Server 2008 data store in Geoserver. I have installed the jar files per the OpenGeo instructions, including the sqljdbc4.jar file, on to ../opengeo-suite/geoserver/WEB-INF/lib/. When I try to create a new Geoserver data store via the OpenGeo dashboard, however, I get the following error:

Error creating data store, check the parameters. Error message: Java Runtime Environment (JRE) version 1.6 is not supported by this driver. Use the sqljdbc4.jar class library, which provides support for JDBC 4.0.

I originally had both sqljdbc.jar and the sqljdbc4.jar files loaded in the lib folder, but I removed the sqljdbc.jar, assuming Geoserver was getting confused. However, I'm still encountering this problem. Should I change the JRE to a different version? Thanks!

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.