Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I am trying to make use of a live non-cached Data Interoperability (DI) connection to consume a WFS services served by geoserver. The data displays in arcmap fine, and using fiddler to monitor the HTTP traffic, I can see the live http requests and responses as I pan and zoom the map. However, viewing the attribute table, or other operations such as select by rectangle are not working. Looking at the requests and responses with fiddler, the problem seems to be with the format of the filter xml embedded by arc10/DI within the request.

Arc/DI is embedding something like this:

<ogc:Filter>
<ogc:PropertyIsEqualTo>
<ogc:PropertyName>SomeProperty</PropertyName>
<ogc:Literal>100</Literal>
</ogc:PropertyIsEqualTo>
<ogc:/Filter>

The server is failing to parse this filter xml.

When I manually edit the xml in the requests within fiddler to this (ie drop the ogc namespace)

<Filter>
<PropertyIsEqualTo>
<PropertyName>SomeProperty</PropertyName>
<Literal>100</Literal>
</PropertyIsEqualTo>
</Filter>

the server understands the request and send the feature gml back.

Is this is a bug on the Arc/DI side?

share|improve this question
    
Do you know which software provides the WFS? It depends on the XML parser which is used by the server, if it recognizes namespaced and not namespaced tags as equal. If ESRI defines the namespace "ogc" in its request XML, both variants should be recognized as equal in this case I think. –  Jürgen Zornig May 29 '13 at 12:43
    
sorry, just read Geoserver now. So if ArcGIS has declared the ogc namespace in its request, it is not a bug on the Arc/DI side, but I also do not know if there are known bugs with different versions on the geoserver side. –  Jürgen Zornig May 29 '13 at 12:52

1 Answer 1

In the end we used our server wrapper code to strip the ogc namespace from the filter in the request before forwarding on to geoserver. Another option would have been to add, the ogc namespace url to the ogc:filter element. This would have worked too.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.