Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

ARCGIS 10 and ERDAS 8.7 were already installed in my computer. But I want to open both programs at the same time. If ARCGIS can open properly, ERDAS cann't open and vice verse, showed that following error (Fig.1). error while opening ERDAS

IF I switch off ERDAS using License Manager Tools "LMTOOLS" (Fig.2), then ARCGIS can open properly, If I switch off ARCGIS using the same way above, ERDAS can open properly. in this case, ERDAS has switched off

So what I want to ask are what is the reason for this problem and how to fix it?

Thank you very much


I've changed "any" into 27002 and both "this_host" and "son" into "user_PC" which is my computer full name. This time Erdas can open correctly, but arcgis cannot. The following image is a problem with opeining ARCGIS. error opening arcgis

Can you tell me what this means?

thank you


Thank you for your answer, U2ros. Here I'm adding some more photos of license files. According to your advice, when I opened both license files for arcgis and erdas, they look like this. First image is ARCGIS license file which is very similar with you described above except "son". I think I can change 27001 into 27005 etc. arcgis 10 license file Next image is license file of Erdas. This looks totally different from you described above. Here I'm fully confused which one is port number that I need to change to something like 27002. Can you give me further advice to for this. erdas license file.

Thank you very much

share|improve this question

closed as too localized by Chad Cooper, PolyGeo, BradHards, dassouki, iant Jun 2 '13 at 16:21

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
May I ask if you have completely legal licenses? Maybe you could ask Leica/ESRI support for help? –  Devdatta Tengshe Jun 1 '13 at 14:46
    
You will certainly need to contact your local Esri distributor because it appears you are trying to run ArcGIS 10 using ArcGIS 9.2 licenses. My understanding is that you will need to request a new license file. –  PolyGeo Jun 1 '13 at 22:33
add comment

1 Answer

I think you have a collision in lmgrd process ports. If you edit the licence file in a text editor, you can change the default port that is used by the lmgrd process that uses the licence file. The licence file looks something like this:

--------------
START_LICENSE

SERVER 192.168.1.15 ESRI_SENTINEL_KEY=some_number_here 27006

Note the port used in this case is 27006. Open both licence files for erdas and arcgis and change one to 27001 and the other to 27002 for example, then restart both servers and reread the licences.

share|improve this answer
    
Hello U2ros, I wrote my questions bellow because I don't know the way to add image in this window (add comment window). Can you read that and give me further advice? –  Bandrush Barda May 31 '13 at 19:59
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.