Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to compile the latest PostGIS 2.1.0 beta and the configure process fails at:

checking GDAL version... 1.10.0
checking for OGR enabled... yes
checking gdal.h usability... yes
checking gdal.h presence... yes
checking for gdal.h... yes
checking ogr_api.h usability... yes 
checking ogr_api.h presence... yes
checking for ogr_api.h... yes
checking cpl_conv.h usability... yes
checking cpl_conv.h presence... yes
checking for cpl_conv.h... yes
checking for library containing GDALAllRegister... no
configure: error: could not find GDAL

GDAL is installed to the normal /usr, and gdal-config is in my path, and the process still fails if I specify its location when I call ./configure. Configuration works if I specify --without-raster, but none of the PostGIS extensions are built, only the old fasioned .sql files so I can use ALTER EXTENSION to update my PostGIS database. Any ideas?

share|improve this question
How did you install gdal? – L_Holcombe May 31 '13 at 1:56
Built it myself with the following options: ./configure --prefix=/usr --with-netcdf --with-libtiff --with-sqlite3 \ --with-geotiff --with-mysql --with-python --without-libtool --with-curl \ --with-hdf5 --with-perl --with-geos --with-png \ --with-fgdb=/opt/FileGDB_API – HeyOverThere May 31 '13 at 2:16
It worked just fine with PostGIS the last time I compiled it, that was a SVN pull of PostGIS – HeyOverThere May 31 '13 at 2:17
Have you tried compiling using the -with-gdal-config flag? Example from my system: –with-gdalconfig=/usr/local/bin/gdal-config – L_Holcombe May 31 '13 at 3:28
Take a minute to look the "config.log", usually you can find the error explained. – Taber May 31 '13 at 6:58
up vote 5 down vote accepted

I had this problem and I found out the path to the libraries was missing. To see if something is missing, check the /root/postgis-2.1.0/config.log for hints.

I had traced the following problems while searching for errors in the config.log file by the string 'needed by'.

/usr/bin/ld: warning:, needed by /usr/lib64/, not found
/usr/bin/ld: warning:, needed by /usr/lib64/, not found
/usr/bin/ld: warning:, needed by /usr/lib64//

Solution: I searched for their location by searching for the missing files, E.G. find / -name '' and I found them.

They were in:


I simply added the paths to the file /etc/ which now looks like:


Then run ldconfig and it all worked!

share|improve this answer
My config.log didn't show these info. I had to do ldd on libgdal itself to get the info on the missing libraries. Hope this helps others too! – janechii May 6 '15 at 18:24

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.