Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I'm trying to compile the latest PostGIS 2.1.0 beta and the configure process fails at:

checking GDAL version... 1.10.0
checking for OGR enabled... yes
checking gdal.h usability... yes
checking gdal.h presence... yes
checking for gdal.h... yes
checking ogr_api.h usability... yes 
checking ogr_api.h presence... yes
checking for ogr_api.h... yes
checking cpl_conv.h usability... yes
checking cpl_conv.h presence... yes
checking for cpl_conv.h... yes
checking for library containing GDALAllRegister... no
configure: error: could not find GDAL

GDAL is installed to the normal /usr, and gdal-config is in my path, and the process still fails if I specify its location when I call ./configure. Configuration works if I specify --without-raster, but none of the PostGIS extensions are built, only the old fasioned .sql files so I can use ALTER EXTENSION to update my PostGIS database. Any ideas?

share|improve this question
    
How did you install gdal? –  L_Holcombe May 31 '13 at 1:56
    
Built it myself with the following options: ./configure --prefix=/usr --with-netcdf --with-libtiff --with-sqlite3 \ --with-geotiff --with-mysql --with-python --without-libtool --with-curl \ --with-hdf5 --with-perl --with-geos --with-png \ --with-fgdb=/opt/FileGDB_API –  HeyOverThere May 31 '13 at 2:16
    
It worked just fine with PostGIS the last time I compiled it, that was a SVN pull of PostGIS –  HeyOverThere May 31 '13 at 2:17
1  
Have you tried compiling using the -with-gdal-config flag? Example from my system: –with-gdalconfig=/usr/local/bin/gdal-config –  L_Holcombe May 31 '13 at 3:28
    
Take a minute to look the "config.log", usually you can find the error explained. –  Taber May 31 '13 at 6:58
show 1 more comment

1 Answer

up vote 2 down vote accepted

I had this problem and I found out the path to the libraries were missing. To see if something is missing, check the /root/postgis-2.1.0/config.log for hints.

I had traced the following problems while searching for errors in the config.log file by the string 'needed by'. /usr/bin/ld: warning: libhdf5.so.6, needed by /usr/lib64/libgdal.so, not found /usr/bin/ld: warning: libpq.so.5, needed by /usr/lib64/libgdal.so, not found /usr/bin/ld: warning: libhdf5_hl.so.6, needed by /usr/lib64//libnetcdf.so.6

Solution: I searched for their location by searching for the missing files, E.G. find / -name 'libhdf5.so.6' and I found them.

They were in: */usr/lib64/mpich2/lib/*libhdf5.so.6. */usr/lib64/mpich2/lib/*libhdf5_hl.so.6 */opt/postgresql/9.3/lib/*libpq.so.5

I simply added the paths to the file /etc/ld.so.conf which now looks like:

include ld.so.conf.d/*.conf
/opt/postgresql/9.3/lib/
/usr/lib64/mpich2/lib/

Then run ldconfig and it all worked!.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.