Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I am continuing work that another person began based on Geoserver and postgis. On the database level there are many tables and the layers are views based on these tables. That is working great!

Now I want to create some other tables and views. I have also been adding them to GeoServer. In order to check if this is working I selected the Layer Preview opyion and I clicked on Open Layer in the Common Formats column. The result is that a popup is displayed to download an XML file, but when I open it, it says:

<ServiceExceptionReport version="1.1.1">
    <ServiceException> java.lang.NullPointerException null </ServiceException>
</ServiceExceptionReport>

For the layers created by the other person, this works fine. I compared two layers and they seem to be similar, so what am I doing wrong?

PS: All layers are converted from shapefiles to postgis.

share|improve this question
    
Check the 'Layer style' at first.. –  Sandipan Saha Jun 11 '13 at 5:05

1 Answer 1

up vote 2 down vote accepted

My solution was go to option server state -> reload and that is all.

share|improve this answer
    
Please mark this as the accepted solution, so that future readers with the same problem will know what worked. Thanks. –  user3461 Jun 11 '13 at 11:07
    
GeoKevin, I can accept it tomorrow due to platform restriction. –  Overflow012 Jun 11 '13 at 11:28
    
Understood. Thanks (in advance) for accepting it, and thereby keeping the site running well. –  user3461 Jun 11 '13 at 14:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.