Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

How to add AutoCAD Mtext to GIS attribute table using FME?

What transformer I should use? The reader file in CAD and I want to transform it to GIS Shapefile. In this case I want to expose the attribute from text (fme_text_string) to DC_LAND_PARCEL_BOUNDARY(polygon geometry). So how to expose the attribute along with the value, so that in ArcGIS i only turn on the labeling options to show the annotation.

share|improve this question
    
Does it have to be a shapefile? - you will get better results with converting cad annotation to file geodatabase annotation. –  Mapperz Jun 12 '13 at 13:39
    
Is FME your only software option? I suggest autocad map. I can script it and run it on multiple drawings with perfect results. And with fme enabled on map it will write any format just like fme. –  Brad Nesom Jun 13 '13 at 4:07
    
yes..it have to be shapefile..but i want to convert cad annotation to the attribute table..the cad annotation that belong to the certain feature layer (for example road) are assign in attribute table of the layer road in GIS. –  AMIR Jun 14 '13 at 2:35

2 Answers 2

For arcgis the solution is to convert the Annotation to points and then Spatial join them to the parcels.

share|improve this answer
    
Please explain your answer in detail –  Sunil Jun 12 '13 at 5:19
    
how about using FME?any solution? –  AMIR Jun 12 '13 at 5:24

First add the Autocad annotation layer in ArcGIS. Open the table of this layer and write down the fields you want to have in your shapefile.

Now create a point shapefile and add the same fields. Start editing the shapefile and just copy-paste the autocad annotation in the shapefile.

The table in the shapefile should now contain the text displayed in the annotation so now you can just label the points in ArcGIS.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.