Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I am trying to convert a small DEM (1 megabyte) into contours. When I go to - Extraction - Contour- and run it I get the following message:

"ERROR 1: CPLRealloc(): Out of memory allocating 416 bytes." It doesn't seem to matter what the contour interval is, although I will get a slightly different error message (for example 40 bytes). And, I have successfully converted a much larger DEM in the past. Now I get the same error message when I attempt to convert that one to contours as well.

Computer doesn't have the most power, but it worked in the past. Windows 7 Professional, 2 gigabytes of RAM, I have tried different contour intervals, checked the projection, made sure no other applications were running, and can't think of what else might be going wrong.

share|improve this question
    
Sounds like a bug. Please post it on the QGIS bugtracker instead of here and provide an example dataset as well, where the error occurs. As the contour function works without issues for me i believe it must have something to do with your data. –  Curlew Jun 12 '13 at 22:36
    
Okay, I will post it. I was downloading a DEM based on LIDAR for the CA Coast (From NOAA Digital Coast). Part of the DEM had no data in it which caused QGIS to give me the error. Once I clipped it to only include a portion of the area with data everything started to work fine. –  Peter Jun 13 '13 at 22:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.