Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I have a table with a row Page_Number_N some of the rows have values and others just have a space. For example record 4 is just a space. Field values are Strings.

1
2
3

5

When I start an edit session and delete the space it deletes it. However, as soon as I save edits. Boom the space in the data returns...

I have tried removing the space in the field calc without edit session turn on and same result.

I need this record to equal "" ie. No spaces or null and I can't seem to get ESRI to cooperate.

Does anyone know how to fix this?

[EDIT] Clarification.

share|improve this question
    
NVM FOUND OUT WHY IT NOT WORKING. Shapefiles have serious problems with attributes. For example, they cannot store null values, they round up numbers, they have poor support for Unicode character strings, they do not allow field names longer than 10 characters, and they cannot store both a date and time in a field. In short NULL values are not allowed in shapefiles. –  TForward Jun 23 '13 at 16:56
1  
Why does the record have to equal an empty string? If for whatever reason it must, import your shapefile to a geodatabase. –  Paul Jun 23 '13 at 17:41
    
It needs to be empty because on data driven pages adjacent pages where displayed as "See Page " when they should be showing up as "[empty]" so they don't appear when printing. –  TForward Jun 23 '13 at 18:34
    
how can I make field on my table reject blank space during and after editing? –  user33133 Jul 3 at 12:15
    
If you have a new question, please ask it by clicking the Ask Question button. Include a link to this question if it helps provide context. –  Martin Jul 3 at 13:15
add comment

1 Answer 1

Unfortunately, as you commented above, shapefiles do not support NULL values which is documented here:

Until, your question I had not noticed that the blank space (" ") in a text field of a shapefile could not be replaced by nothing ("") but I tested and can confirm that.

If you have this requirement it represents another reason for using file geodatabases rather than shapefiles with ArcGIS for Desktop. Fortunately, the conversion is simple.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.