Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

If the "Register for COM interop" is unchecked the projects builds without errors.

VS2010 Project Properties Build Tab

But I have to reference external ActiveX Interface in my project so I have to have that check-box checked. I am getting the build error:

Cannot register assembly "...\MyCustomArcMapAddIn.dll". Could not load file or assembly 'ESRI.ArcGIS.Desktop.AddIns, Version=10.1.0.0, Culture=neutral, PublicKeyToken=8fc3cc631e44ad86' or one of its dependencies. The system cannot find the file specified.

Is there workaround here? Thanks

share|improve this question

1 Answer 1

up vote 1 down vote accepted

The newer type of ArcGIS Add-in's do not get registered for COM interop. However, You can use ActiveX controls in an Add-in without using this option. The controls should be installed separately before the Add-in. For example, you can use Microsoft ReportViewer with an add-in if it is installed on the machine already.

share|improve this answer
    
Thanks. Makes sense. I built the ActiveX in separate project, installed it separately and I can use it without checking that option "Register for COM interop" –  mitaka Jun 28 '13 at 15:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.