Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I know this has probably been covered and that there are plenty of guides out there, but for the life of me I cannot get pgrouting installed. All guides/how-tos are different or assume prior knowledge. I'm a QGIS newbie and please assume I know nothing!

How do install pgrouting? And what do I need first and how do I install whatever is needed? Can some helpful soul offer a step-by-step guide?

I've been trying to do this for days. I can get Postgres installed but the Stack Builder will not connect. I am thoroughly confused.

I'm using Windows 7 Enterprise 64bit Service Pack 1, QGIS Lisboa.

I'm now having trouble getting PostgreSQL to install.

Loading additional SQL modules...

Executing cscript //NoLogo "C:\Program Files (x86)\PostgreSQL\9.2\installer\server\loadmodules.vbs" "postgres" "**" "C:\Program Files (x86)\PostgreSQL\9.2" "C:\Program Files (x86)\PostgreSQL\9.2\data" 5432 Script exit code: 2

Script output: Installing the adminpack module in the postgres database... Executing 'C:\Users\ucesga1\AppData\Local\Temp\rad87BB2.bat'... psql: could not connect to server: Connection refused (0x0000274D/10061) Is the server running on host "localhost" (::1) and accepting TCP/IP connections on port 5432? could not connect to server: Connection refused (0x0000274D/10061) Is the server running on host "localhost" (127.0.0.1) and accepting TCP/IP connections on port 5432?

Failed to install the 'adminpack' module in the 'postgres' database loadmodules.vbs ran to completion

Script stderr: Program ended with an error exit code

Error running cscript //NoLogo "C:\Program Files (x86)\PostgreSQL\9.2\installer\server\loadmodules.vbs" "postgres" "**" "C:\Program Files (x86)\PostgreSQL\9.2" "C:\Program Files (x86)\PostgreSQL\9.2\data" 5432 : Program ended with an error exit code

enter image description here

share|improve this question
1  
It seems that your internet connection via Stack Builder is bad. I think that Proxy servers settings may be necessary. But, if it is difficult, you can download PostGIS installer from postgis.net/windows_downloads and, pgRouting Windows binary is here(winnie.postgis.net/download/windows/pg92/buildbot ) –  sanak Jul 1 '13 at 12:31
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.