Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

Using a default installation of the 3.0.2 suite, opening the Composer view(with the MapQuest OSM tiles as background) and clicking print (to pdf) to activate the print preview there appears to be a couple of issues with the scale given in the scale selector box.

One- if one slides the zoom slider so that the scale selector box gives 1:512 000, and then opens the scales list in the box and chooses 1:512 000 the scale visibly changes in the print preview map (it goes to the next smaller scale).

Two- the scales in the scales list in the scale selector box do not entirely match the list of scales given in config.yaml: the smallest (1:524288000) is not listed.

Three - there are 17 zoom levels in the default Composer map, 18 in the print preview's zoom slider, and 19 in the scale selector box.

The scales given by the zoom slider in the default Composer map roughly match the scales given in Config.yamls, i.e 1:68k something becomes 1:64k etc, but this should not be reason for this default behaviour?

I have tried changing the number of scales config.yaml as well as changed the maxZoomLevels for the map, but besides zoom slider in the print preview following the number of zoom levels (scales) of maxZoomLevels, even if the main map's zoom slider does not, I cannot get things to precisely line up.

A search here and abroad did not reveal this issue described, but if parts of this (or all) is due to a lack of understanding of certain fundamentals on my side, then pray tell where I can go read :)

Many thanks for reading.

share|improve this question

1 Answer 1

You may want to play with the DPI setting in the config.yaml to match scales better. GeoExplorer uses 90.7142857142857 DPI, so it is a good idea to try multiples of that.

share|improve this answer
    
Hi, many thanks for your answer! –  David I Jul 4 '13 at 13:47
    
Sorry about that, I did not realize the return key would post, rather then issue a carriage return :) I meant to reply: "Hi, many thanks for your answer! The list of allowable resolutions of the resulting pdf is "dpis: [75, 150, 300]" by default, and changing these do not appear to have any effect on the issues mentioned above. They are in the default setup, so I'm wondering whether anyone has an OpenGeo Suite with a print module void of them? The final two are a bit mysterious, but the first issue can cause rather anomalous map pdfs." –  David I Jul 4 '13 at 13:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.