Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.


I've built a model which interpolates series of data by IDW method and it works well. But when I tried to change method of interpolation to kriging I encountered some problems with using Z value field as a variable.
Here are some pictures that may help to explain my problem:
how the data look like: http://imageshack.us/a/img22/4167/l4th.jpg
IDW version: http://imageshack.us/a/img221/1879/qegc.png
I'm using 'For' iterator and variable for Z value field 'a%Value%' so every iteration is using next data field as Z values. And values of the iterator are preconditions to interpolation. It's is basically the same model in both versions but I don't know why the variable isn't working with kriging. When I open the Kriging tool I've got this error in Z value field:

ERROR 001000 Z value field: Field a%Value% does not exist

but in the IDW version it works well. Any ideas?

share|improve this question
    
Obvious dumb question, your for loop is it looping over the correct range of values and not starting at Zero? Your example image suggests it should be over a range of 1 to 6 –  Hornbydd Jul 5 '13 at 16:33
    
I'm starting from 1. The thing is that this model with IDW interpolation works but when I change the method of interpolation to Kriging I've got errors. But entire model is basically the same except method of interpolation. –  Mat Jul 5 '13 at 20:17
    
Sounds like you've found (yet another) bug. May be worth logging it with ESRI. –  Hornbydd Jul 5 '13 at 21:37
1  
Thanks for response. It looks like it is a bug indeed. Anyway I figured out that I was using IDW interpolation from Geostatistical Analyst toolbox and then I tried to use kriging form Spatial Analyst. When I changed IDW method from Geostatistical to the one from Spatial Analyst toolbox I've encountered the same problem with iteration so I assume that this method of iteration only works with tools from the Geostatistical Analyst. –  Mat Jul 17 '13 at 11:04
    
It might help to know that SA and GA are completely different, having been written independently at different times by different non-interacting groups. It would be wise to stick to one or the other during a calculation, if at all possible. –  whuber Jul 17 '13 at 13:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.