Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

Actually in a practical Project we wanted to use OpenLayer and MapServer to display our data using WMS, but
We can't find a proper srs or EPSG code. One of the ITC students said, we have to change our MapServer software! I'm not sure it's an effective solution. I will absolutely delighted that you give me a helping hand.

I set the map file but when I used WMS, The map loaded but anything didn't show.
How can one fix it?

This is .proj file of a layer:

> PROJCS["WGS_1984_Lambert_Conformal_Conic",  
GEOGCS["GCS_WGS_1984",  
DATUM["D_WGS_1984",  
SPHEROID["WGS_1984",6378137.0,298.257223563]],  
PRIMEM["Greenwich",0.0],UNIT["Degree",0.0174532925199433]],  
PROJECTION["Lambert_Conformal_Conic"],  
PARAMETER["False_Easting",0.0],  
PARAMETER["False_Northing",0.0],  
PARAMETER["Central_Meridian",54.0],  
PARAMETER["Standard_Parallel_1",30.0],  
PARAMETER["Standard_Parallel_2",36.0],  
PARAMETER["Latitude_Of_Origin",24.0],  
UNIT["Meter",1.0]]  

Thanks for your comment.
This is my config file!
I don't khnow how can I attch my shp file.

MAP
FONTSET  "fonts/fonts.list"  

NAME Iran  
IMAGECOLOR 255 255 255  
SIZE 600 800  

I don't know Which ESPG code I can use!

WEB  
IMAGEPATH "/tmp/ms_tmp/"  
IMAGEURL "/ms_tmp/"  
METADATA  
  "map" "C:/ms4w/apps/Iran/config.map"  
  "ows_schemas_location" "http://schemas.opengeospatial.net"  
  "ows_title" "Sample WMS"  
  "ows_abstract" "Stations"  
  "ows_keywordlist" "Stations,WMS,Raymand"  
  "ows_onlineresource" "--/cgi-bin/mapserv.exe?map=c:/ms4w/apps/Iran/config.map&"  
  "wms_srs" "EPSG:4326 " #latlon       
  "wms_feature_info_mime_type" "text/plain"  
  "wms_feature_info_mime_type" "text/html"  
  "wms_server_version" "1.1.1"  
  "wms_formatlist" "image/png,image/gif,image/jpeg"  
  "wms_format" "image/gif"  
 END #metadata  
 END #web  

LAYER  
NAME allStations  
TYPE POINT  
STATUS ON  
TOLERANCE 8  
TOLERANCEUNITS pixels  
DATA data/allStations  
METADATA  
  "wms_title" "allStations"  
  "wms_include_items" "all"  
END  

END #layer allStations  
LAYER  
NAME "province"  
TYPE POLYGON  
STATUS ON  
TOLERANCE 8  
TOLERANCEUNITS pixels  
DATA data/province  
METADATA  
  "ows_title" "province"  
  "wms_include_items" "all"  
END #metadata  
END #layer proviance  

SCALEBAR  
IMAGECOLOR 255 255 255  
LABEL  
 COLOR 0 0 0  
 SIZE TINY  
END  

STYLE 1  
SIZE 130 2  
COLOR 0 0 0  
UNITS KILOMETERS  
INTERVALS 2  
TRANSPARENT FALSE  
STATUS ON  
POSITION LR  
END #scalebar  

END #map
share|improve this question
1  
explain better your problem and post some code, in that way we can help you easily. I don't think you need to change your Mapserver software, I don't know why he/she meant that. –  Gery Jul 17 '13 at 10:29
    
did you try prj2epsg.org/search –  iant Jul 17 '13 at 10:58
    
The first problem is I don't Know how can set the ESPG code for my layers with that Reference system and the other is, I chose espg:4326; then I sent a WMS request. I received the img file, and I can Zoom-in or Zoom-out on it but anything didn't show. just cursor had changed from from pointer to zoom-in icon. –  Raha1986 Jul 17 '13 at 11:14
    
I Change the Geographic coordinate system from Lambert to WGS84 and it works!:) –  Raha1986 Jul 17 '13 at 13:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.