Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I'm using the latest and greatest Silverlight with ArcGIS Server 10 and when I do a search for features in my operational layers (wells) and zoom into them I'm seeing "Map Data Not Yet Available" because there are no Tiles created at the scale I have zoomed into. I published my Operational data from a MSD and it runs great and I added in a ESRI Streets layer service using manager. The only way I have found to control the scales of the Tiled ESRI service is to create a Group layer in the MXD and publish the MXD straight to a service. This will not work for me because the performance is too slow. Does anyone have any suggestions?

Many thanks -Josh

share|improve this question
    
If you just have one well selected, how do you decide on extent? –  Kirk Kuykendall Mar 1 '11 at 15:32
    
The Viewer I'm using seems to zoom to the extent of the selected feature –  user2097 Mar 1 '11 at 15:38
    
why don't you only zoom in as far as tiles were created? Your group layer mxd thing sounds convoluted to me. –  Steve Mar 1 '11 at 17:25

3 Answers 3

You can set a minimum extent in the Silverlight API to ensure that the user can not zoom in beyond that scale.

share|improve this answer
    
How and where do you set that Seth? –  user2097 Mar 1 '11 at 15:37
1  
There are a few different ways, depending on what information you have. Probably the simplest is to use the MinimumResolution property on the Map control. More info can be found here: resources.esri.com/help/9.3/arcgisserver/apis/silverlight/… –  Seth P. Mar 1 '11 at 16:34
1  
The map control has an ExtentChanged event. If you put a breakpoint there, you can check it once you are at the resolution you want. The map control has an attribute called "Resolution" which will give you the value you will want to put in the MinimumResolution property. –  Seth P. Mar 1 '11 at 16:42
    
The streets layer has several levels of "Map Data not yet Available" tiles. If you look at the services directory page - server.arcgisonline.com/ArcGIS/rest/services/World_Street_Map/… You can see what resolution corresponds to each zoom level. Open the map in the Javascript viewer and use firebug or Chrome's development tools to look at the tile images that are loaded as you zoom in, the tile level will be in the path of each tile image. Looks like level 16 should be ok for most areas, which would be Resolution: 2.38865713397468. –  wwnick Mar 1 '11 at 19:20
    
@Josh - Did you try setting @wwnick's value in your minimumresolution attribute? –  Seth P. Mar 2 '11 at 7:34

The "No Data Available" may actually be legitimate tiles coming from the ArcGIS Online map.

You could defeat those tiles by toggling the transparency of the service at certain zoom levels.

Do you have interpolation set up on your map control? (Does it allow zooming to any scale, or just the cached ones?)

share|improve this answer
  1. Accessing an html page via the file system will not allow remote map services to display within the Map control. By default files accessed via the file system in a browser have restricted access to remote services which includes ArcGIS Online services.
  2. In order to access an ArcGIS Server site on a different domain than the Silverlight application host site, the ArcGIS Server site must enable remote access to services. This is accomplished using a clientaccesspolicy.xml or crossdomain.xml. In most cases, just place the xml file at the root of your Web site (e.g. for IIS, C:\inetpub\wwwroot).

http://help.arcgis.com/en/webapi/silverlight/help/?Whats_New.htm#/Getting_Started/016600000004000000/

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.